1. 程式人生 > >Max Sum(dp水題)

Max Sum(dp水題)

還是子序列求和

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 186386    Accepted Submission(s): 43487


Problem Description Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input 2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output Case 1: 14 1 4 Case 2: 7 1 6
#include <cstdio>
int main(){
    int t;
    scanf("%d",&t);
    for(int Case=1;Case<=t;Case++){
        int a,max_sum=-1001,max_first,max_last,tot=-1,last,first;
        int d;
        scanf("%d",&d);
        for(int i=1;i<=d;i++){
            scanf("%d",&a);
            if(tot<0){
                first=last=i;
                tot=a;
            }
            else {
                tot+=a;last=i;
            }
            if(tot>max_sum){
                max_sum=tot;
                max_first=first;
                max_last=last;
            }
        }
    printf("Case %d:\n%d %d %d\n",Case,max_sum,max_first,max_last);
    if(Case!=t)printf("\n");
    }
    return 0;
}
AC之路,我選擇堅持~~