1. 程式人生 > >hdu 4006 The kth great number(優先佇列)

hdu 4006 The kth great number(優先佇列)

Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an ” I” followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a “Q”, then you need to output the kth great number.

Output
The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

Hint
Xiao Ming won’t ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=< k<=n<=1000000).

#include<iostream> 
#include<queue>
using namespace std;
int main()
{
    int n,k,y,x;
    char c;
    while(cin>>n>>k)
    {
        priority_queue<int,vector<int>,greater<int> >q;  //按數的值從大到小排序 
        while(n--)
        {
            cin>>c;
            if
(c=='I') { cin>>x; if(q.size()==k) //如果佇列裡面已經有k個數 { y=q.top(); //取隊頭,也就是第k大的數 if(x>y) //如果輸入的數x比第k個數大 { q.pop(); //隊頭元素出隊 q.push(x); //將輸入的數x元素壓入隊中 } } else q.push(x); //如果不夠k個數,就一直壓入隊中 } else cout<<q.top()<<endl; //否則只要每次輸出隊頭元素即可 } } return 0; }