1. 程式人生 > >A Knight's Journey(深度搜索)

A Knight's Journey(深度搜索)

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 42686 Accepted: 14506

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem

Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int vis[10][10];
int s[10][10]={{-2,-1},{-2,1},{-1,-2},{-1,2},{1,-2},{1,2},{2,-1},{2,1}};//按字典序輸出,x從小到大
int x1[30],y1[30];
int p,q,flag,n;
void dfs(int x,int y,int step)
{
   x1[step]=x;
   y1[step]=y;
   if(step==p*q)
   {
      flag=1;
      return ;
   }
   for(int i=0;i<8;i++)
   {
       int tx=x+s[i][0];
       int ty=y+s[i][1];
       if(1<=tx&&tx<=q&&1<=ty&&ty<=p&&!flag&&!vis[tx][ty])//注意p和q
       {
          vis[tx][ty]=1;
          dfs(tx,ty,step+1);
          vis[tx][ty]=0;

       }
   }
  return ;
}
int main()
{
    scanf("%d",&n);
    
    for(int k=1;k<=n;k++)
    {
        flag=0;
        scanf("%d%d",&p,&q);
        memset(vis,0,sizeof(vis));
        vis[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",k);
        if(flag)
        {
           for(int i=1;i<=p*q;i++)
           {
               printf("%c%d",x1[i]-1+'A',y1[i]);
           }
        }
        else
        printf("impossible");
        if(k==n)
        printf("\n");
        else
        printf("\n\n");//注意格式
    }
    return 0;
}