1. 程式人生 > >1039 Course List for Student(字符串哈希)

1039 Course List for Student(字符串哈希)

code -html style test extra 字符串哈希 ast 使用二維數組 orm

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤), the number of students who look for their course lists, and K (≤), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N?i?? (≤) are given in a line. Then in the next line, N?i?? student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student‘s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0

註意點:

  1. map<string, vector<int> >會導致超時
  2. 數據量龐大,不要使用cin和cout輸入輸出
  3. 使用二維數組,會導致最後一組數據內存超限,因此需要使用vector

總的來說,這算是一道套路題,字符串都給的簡短且工整正是暗示了轉化哈希的思路,vector的使用也不復雜,趟過這個坑這類題以後應該問題不大。

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=26*26*26*10+1;
vector<int> v[maxn];

int get(char c[]){
    int id=0;
    for(int i=0;i<3;i++){
        id=id*26+c[i]-A;
    }
    id=id*10+c[3]-0;
    return id;
}

int main(){
    int n,m,a,b;
    char temp[5];
    scanf("%d%d",&n,&m);
    for(int i=0;i<m;i++){
        scanf("%d%d",&a,&b);
        for(int j=0;j<b;j++){
            scanf("%s",temp);
            int id=get(temp);
            v[id].push_back(a);
        }
    }
    for(int i=0;i<n;i++){
        scanf("%s",temp);
        int id=get(temp);
        sort(v[id].begin(),v[id].end());
        printf("%s %d",temp,v[id].size());
        for(int j=0;j<v[id].size();j++)
            printf(" %d",v[id][j]);
        printf("\n");
    }
    return 0;
}

1039 Course List for Student(字符串哈希)