1. 程式人生 > >poj 1459 Power Network 初級->圖演算法->最大流(基本演算法:增廣路)

poj 1459 Power Network 初級->圖演算法->最大流(基本演算法:增廣路)

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 19197 Accepted: 10125

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax
(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax
(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax
(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6
BFS找增廣路
#include<iostream>
#include<cstring>
#include<vector>
#include<queue>
using namespace std;

const int inf=10001;

vector<int> node[103];//記錄和當前節點相連線的節點
struct node_1
{
    int pre; //當前節點的前驅節點
    int lv; //當前節點的容量
}node1[103];
int n,np,nc,line; //n個節點、np個發電站、nc個使用者、line條邊
int s,t; // 超級源點、超級匯點
int cap[103][103]; //弧(u,v)的容量
int flow[103][103]; //弧(u,v)的流量
bool vist[103]; //標記陣列

int min(int a,int b)
{
    return a<b?a:b;
}

void back()
{
  int x=t;
  while(x!=s)
  {
    flow[node1[x].pre][x]+=node1[t].lv;//改進增廣路
    x=node1[x].pre; //x變為其前驅節點,繼續向s推進,直到修改到s結束
  }
}

bool bfs()
{
  queue<int> q;
  int i;
  memset(vist,false,sizeof(vist));
  node1[s].pre=-1;
  node1[s].lv=inf; //初值賦為無窮
  vist[s]=true;
  q.push(s);
  while(!q.empty())
  {
    int x,y;
    x=q.front();
    int SI=node[x].size();
    for(i=0;i<SI;i++)
    {
      y=node[x][i];
      if(!vist[y]&&flow[x][y]<cap[x][y])
      {
        q.push(y);
        vist[y]=true;
        node1[y].pre=x;
        node1[y].lv=min(node1[x].lv,cap[x][y]-flow[x][y]);
      }
      if(vist[t]) break;
    }
    if(!vist[t]) q.pop(); // 出隊
    else return true;//找到一條增光路,返回true
  }
  return false; //如果佇列空時也沒有找到增光路,那麼返回false
}

int main()
{
    int i,u,v,z,sum;
    char ch;
    while(cin>>n>>np>>nc>>line)
    {
      for(i=0;i<=102;i++) //容器初始化
      node[i].clear();
      s=n; t=n+1;
      for(i=1;i<=line;i++)
      {
        cin>>ch>>u>>ch>>v>>ch>>z;
        if(u==v) continue; //對環不進行處理
        cap[u][v]=z;
        flow[u][v]=0; // 每條邊的流量都初始化為0
        node[u].push_back(v);
      }
      for(i=0;i<np;i++)
      {
        cin>>ch>>v>>ch>>z;
        cap[s][v]=z; //建立超級源點,指向所有電站
        flow[s][v]=0;
        node[s].push_back(v);
      }
      for(i=0;i<nc;i++)
      {
        cin>>ch>>u>>ch>>z;
        cap[u][t]=z; //建立超級匯點,被所有使用者指向
        flow[u][t]=0;
        node[u].push_back(t);
      }

      for(;;) //找增廣路
      if(bfs()) // 如果找到了增光路
        back(); // 就進行修改
      else
        break; // 直到找不到增廣路退出迴圈

      sum=0; //初始化最大流
      int SI=node[s].size(); //和s相連線的節點的個數
      for(i=0;i<SI;i++)
      sum+=flow[s][node[s][i]]; //求和
      cout<<sum<<endl;
    }
    return 0;
}