1. 程式人生 > >CSU-2031 Barareh on Fire

CSU-2031 Barareh on Fire

and break bar rtu with scanf ret positive mem

CSU-2031 Barareh on Fire

Description

The Barareh village is on fire due to the attack of the virtual enemy. Several places are already on fire and the fire is spreading fast to other places. Khorzookhan who is the only person remaining alive in the war with the virtual enemy, tries to rescue himself by reaching to the only helicopter in the Barareh villiage. Suppose the Barareh village is represented by an n × m grid. At the initial time, some grid cells are on fire. If a cell catches fire at time x, all its 8 vertex-neighboring cells will catch fire at time x + k. If a cell catches fire, it will be on fire forever. At the initial time, Khorzookhan stands at cell s and the helicopter is located at cell t. At any time x, Khorzookhan can move from its current cell to one of four edge-neighboring cells, located at the left, right, top, or bottom of its current cell if that cell is not on fire at time x + 1. Note that each move takes one second. Your task is to write a program to find the shortest path from s to t avoiding fire.

Input

There are multiple test cases in the input. The first line of each test case contains three positive integers n, m and k (1 ? n,m,k ? 100), where n and m indicate the size of the test case grid n × m, and k denotes the growth rate of fire. The next n lines, each contains a string of length m, where the jth character of the ith line represents the cell (i, j) of the grid. Cells which are on fire at time 0, are presented by character “f”. There may exist no “f” in the test case. The helicopter and Khorzookhan are located at cells presented by “t” and “s”, respectively. Other cells are filled by “-” characters. The input terminates with a line containing “0 0 0” which should not be processed.

Output

For each test case, output a line containing the shortest time to reach t from s avoiding fire. If it is impossible to reach t from s, write “Impossible” in the output.

Sample Input

7 7 2
f------
-f---f-
----f--
-------
------f
---s---
t----f-
3 4 1
t--f
--s-
----
2 2 1
st
f-
2 2 2
st
f-
0 0 0

Sample Output

4
Impossible
Impossible
1

題意

給定一個n*m的矩陣,其中s代表起點,t代表終點,f代表著火的點,著火的點每過k時間就會點燃相鄰的八個格子,問能否從起點到達終點,不能輸出impossible,能輸出最短時間(每一次移動消耗1秒,只能上下左右移動)

題解

先預處理出每個點會在多少秒著火,然後bfs即可

#include<bits/stdc++.h>
#define maxn 150
using namespace std;
const int inf = 1e9;
int n, m, k;
char G[maxn][maxn];
int d[maxn][maxn];
int fire[maxn][maxn];

struct point {
    int x, y;
    point(int x = 0, int y = 0): x(x), y(y) {}
} s, t;
queue<point> q;
void init() {
    int dx[9] = { -1, -1, -1, 0, 0, 1, 1, 1 };
    int dy[9] = { -1, 0, 1, -1, 1, -1, 0, 1 };
    while (!q.empty()) {
        point now = q.front(); q.pop();
        for (int i = 0; i < 8; i++) {
            point next = point(now.x + dx[i], now.y + dy[i]);
            if (next.x > 0 && next.x <= n && next.y > 0 && next.y <= m) {
                if (fire[next.x][next.y] > fire[now.x][now.y] + k) {
                    fire[next.x][next.y] = fire[now.x][now.y] + k;
                    q.push(next);
                }
            }
        }
    }
}
void bfs() {
    q.push(s);
    int dx[4] = { 0, 0, 1, -1 };
    int dy[4] = { -1, 1, 0, 0 };
    while (!q.empty()) {
        point now = q.front(); q.pop();
        for (int i = 0; i < 4; i++) {
            point next = point(now.x + dx[i], now.y + dy[i]);
            if (next.x > 0 && next.x <= n && next.y > 0 && next.y <= m) {
                if (d[now.x][now.y] + 1 >= fire[next.x][next.y]) continue;
                if (d[now.x][now.y] + 1 < d[next.x][next.y]) {
                    d[next.x][next.y] = d[now.x][now.y] + 1;
                    q.push(next);
                }
            }
        }
    }
}
int main() {
    while (scanf("%d%d%d", &n, &m, &k) != EOF) {
        if (n == 0 && m == 0 && k == 0) break;
        for (int i = 1; i <= n; i++) {
            scanf("%s", G[i] + 1);
        }
        for (int i = 1; i <= n; i++) {
            fill(d[i] + 1, d[i] + m + 1, inf);
            fill(fire[i] + 1, fire[i] + m + 1, inf);
        }
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= m; j++) {
                if (G[i][j] == 's') {
                    s.x = i; s.y = j;
                    d[i][j] = 0;
                }
                if (G[i][j] == 't') {
                    t.x = i; t.y = j;
                }
                if (G[i][j] == 'f') {
                    fire[i][j] = 0;
                    q.push(point(i, j));
                }
            }
        }
        init();
        bfs();
        if (d[t.x][t.y] == inf) printf("Impossible\n");
        else printf("%d\n", d[t.x][t.y]);
    }
    return 0;
}
/**********************************************************************
    Problem: 2031
    User: Artoriax
    Language: C++
    Result: AC
    Time:12 ms
    Memory:2352 kb
**********************************************************************/

CSU-2031 Barareh on Fire