1. 程式人生 > >POJ 1753 Flip Game【翻轉棋盤+列舉+dfs】

POJ 1753 Flip Game【翻轉棋盤+列舉+dfs】

方法:一、列舉(此處所用)

          二、用二進位制記錄下標(尚未實現)

         三、類比於玩魔方遊戲(思路來自黃超,尚未實現)

Flip Game
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21024 Accepted: 9108

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

Source

題意:          給你一個4*4棋盤,上面有且僅有白色(w)和黑色(b)兩種顏色標記,並且,如果正面是白色,反面則是黑色,反之亦然。 現在讓你翻轉棋盤,問最少翻轉多少次,使得最後棋盤的顏色統一(即全為白色或者全為黑色)。         如果不能翻轉成功,則輸出Impossible;否則,輸出翻轉成功的最小次數。 注意:翻轉方法,如果你翻轉了一個棋盤的格子,那麼此格子的上下左右格子就均被翻轉。 演算法:列舉+dfs+回溯
#include<stdio.h>
#include<iostream>
using namespace std;
int chess[4][4];
int c=33;
void build()//將棋盤的顏色以標記化
{
    char c;
    int i,j;
    for(i=0;i<4;i++)
    for(j=0;j<4;j++)
    {
        cin>>c;
        if(c=='w')
        chess[i][j]=0;
        else
        chess[i][j]=1;
    }
}
void turn(int x,int y)//翻轉
{
     if(x>=0&&x<=3&&y>=0&&y<=3)
     chess[x][y]=!chess[x][y];
}
void flip(int s)//一個棋子變化,周圍四個都要變化
{
    int i=s/4;//行
    int j=s%4;//列
    turn(i,j);
    turn(i+1,j);
    turn(i,j+1);
    turn(i-1,j);
    turn(i,j-1);
}
int complete()//判斷棋盤是否變成同一的顏色
{
    int i,j,s1=0;
    for(i=0;i<4;i++)
       for(j=0;j<4;j++)
          s1+=chess[i][j];
    if(s1%16)
      return 0;
    else
      return 1;
}
void dfs(int s,int b)//進行深搜.s代表當前的方格,b代表翻轉的方格數
{
     if(complete())//如果是同一顏色,找到最終狀態
     {
         if(c>b)
           c=b;
        return;
     }
     if(s>=16)//如果遍歷完
        return;
    dfs(s+1,b);
    flip(s);
    dfs(s+1,b+1);
    flip(s);
}
int main()
{
    build();//將棋盤的顏色以標記化
    dfs(0,0);
    if(c==33)//由於翻轉次數最多為4*4*2=32次
      printf("Impossible\n");
    else
      printf("%d\n",c);
    return 0;
}