1. 程式人生 > >HDU 5532 Almost Sorted Array(最長不下降子序列nlogn模板)

HDU 5532 Almost Sorted Array(最長不下降子序列nlogn模板)

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array. 

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,ana1,a2,…,an, is it almost sorted? InputThe first line contains an integer T
T
 indicating the total number of test cases. Each test case starts with an integer nn in one line, then one line with nn integers a1,a2,,ana1,a2,…,an

1T20001≤T≤2000 
2n1052≤n≤105 
1ai1051≤ai≤105 
There are at most 20 test cases with n>1000n>1000. OutputFor each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes). Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO

題解:

題意:

給你一個序列,讓你從裡面去掉一個使獲得的序列為不上升或者為不下降序列

思路:

直接求最長不下降和不上升序列,看長度值是否為n或者n-1,模板走起

程式碼:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
#define ll long long
#define INF 100861111
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
using namespace std;
const int N = 100001;
int  a[N],b[N],f[N], d[N];	// f[i]用於記錄 a[0...i]的最大長度
int bsearch(const int *f, int size, const int &a)
{
    int  l=0, r=size-1;
	while( l <= r )
	{
        int  mid = (l+r)>>1;
		if( a >= d[mid-1] && a < d[mid] )
			return mid;				// >&&<= 換為: >= && <
		else if( a <d[mid] )
				r = mid-1;
        else l = mid+1;
    }
}
int LIS(const int *a, const int &n)
{
	int  i, j, size = 1;
	d[0] = a[0]; f[0] = 1;
	for( i=1; i < n; ++i )
	{
		if( a[i] < d[0] )			 // <= 換為: <
			j = 0;
		else if( a[i] >= d[size-1] ) // > 換為: >=
			j = size++;
		else
			j = bsearch(d, size, a[i]);

		d[j] = a[i]; f[i] = j+1;
	}
	return size;
}
int main()
{
    int n,i,test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            b[n-i-1]=a[i];
        }
        if(LIS(a,n)>=n-1||LIS(b,n)>=n-1)
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");
    }
    return 0;
}