1. 程式人生 > >劉汝佳的演算法競賽入門經典(第2版) 習題解答

劉汝佳的演算法競賽入門經典(第2版) 習題解答

3-1.1585

There is an objective test result such as ``OOXXOXXOOO". An `O' means a correct answer of a problem and an

`X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous
consecutive `O's only when the answer is correct. For example, the score of the 10th problem is 3 that is
obtained by itself and its two previous consecutive `O's.
Therefore, the score of ``OOXXOXXOOO" is 10 which is calculated by ``1+2+0+0+1+0+0+1+2+3".
You are to write a program calculating the scores of test results.
Input 
Your program is to read from standard input. The input consists of T test cases. The number of test cases T is
given in the first line of the input. Each test case starts with a line containing a string composed by `O' and `X'
and the length of the string is more than 0 and less than 80. There is no spaces between `O' and `X'.
Output 
Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the
score of the test case.
The following shows sample input and output for five test cases.
Sample Input 

OOXXOXXOOO 
OOXXOOXXOO 
OXOXOXOXOXOXOX 
OOOOOOOOOO 
OOOOXOOOOXOOOOX
Sample Output 
10 


55 

30

解答如下:

#include<cstring>
#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<vector>


using namespace std;


int main()
{
    int x,y,T,flag=0,sum=0;
vector<vector<char> > str;
    string s;char c;
    cin>>T;
    for(x=0;x<T;++x)
{
  str.resize(T);
       while((c=getchar())!=EOF && c!='#')
  {
      str[x].push_back(c);
  }
}

    for(x=0;x<T;++x)
{
 sum=0;flag=0;
 for(y=0;y<str[x].size();++y)
 {
    if(str[x][y]=='o' && flag==0)
{
flag=1;
    sum+=1;
}else if(str[x][y]=='o' && flag>0)
{
++flag;
    sum+=flag;
}


if(str[x][y]=='x')
{
    flag=0;
sum+=0;
}


 }


      cout<<sum<<endl;


    }
}

輸出結果截圖為: