1. 程式人生 > >Oil Deposits (dfs)深度搜索

Oil Deposits (dfs)深度搜索

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32295    Accepted Submission(s): 18740


Problem Description The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 1 1 * 3 5 *@*@* **@** *@*@* 1 8 @@****@* 5 5 ****@ *@@*@ *@**@ @@@*@ @@**@ 0 0
Sample Output 0 1 2 2
Source 題意:英語不好, 能懂題意就行。說@是一個有油的地方,@與@相鄰就表示同一個油口袋,斜的也算;比如 @* *@   這兩個@也是同一個油口袋; 這題是一道典型的dfs的題,每次從有@的地方開始dfs向八個方向深搜,直到找不到@為止,將訪問過的位置做標記,下次不再訪問; 看看能進行幾個dfs就會有幾個油口袋; 複製程式碼
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int ivs[110][110];//訪問的標誌,0為未訪問,1為訪問過了 
char a[110][110];
//方向陣列 
int b[]={1,-1,0,0,1,-1,1,-1};
int q[]={0,0,1,-1,-1,1,1,-1};
int r,c;
int dfs(int x,int y)
{
int i,j;
ivs[x][y]=1;
//訪問了 
//向x,y的8個方向深度搜索 
for(i=0;i<8;i++)
{
int ax=x+b[i];
int ay=y+q[i];
//檢視ax,ay是否越界 以及是否被訪問了 
if(ax>=1&&ax<=r&&ay>=1&&ay<=c&&a[ax][ay]=='@'&&!ivs[ax][ay])
{
dfs(ax,ay);
}
}
return 0;
}
int main()
{
while(cin>>r>>c,r&&c)
{
int i,j;
//初始化ivs 
memset(ivs,0,sizeof(ivs));
for(i=1;i<=r;i++)
for(j=1;j<=c;j++)
cin>>a[i][j];
//統計次數 
int sum=0;
for(i=1;i<=r;i++)
{
for(j=1;j<=c;j++)
{
if(a[i][j]=='@'&&!ivs[i][j])
{
dfs(i,j);
ivs[i][j]=1;
sum++;
}
}
}
cout<<sum<<endl;
}
return 0;
}
複製程式碼
人一我百!人十我萬!永不放棄~~~懷著自信的心,去追逐夢想。