1. 程式人生 > >POJ-2318 TOYS 【向量叉積+二分】

POJ-2318 TOYS 【向量叉積+二分】

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box. Input The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0. Output The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line. Sample Input
5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0
Sample Output
0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2
Hint As the example illustrates, toys that fall on the boundary of the box are "in" the box.

題意:

如圖,一塊矩形取餘被n條線段分割成了n+1個區域。給你m個點的座標,求每個區域內各有多少點。

思路:

可以用向量叉積判斷點是線上段的左邊還是右邊。例如判斷點A在向量CD的哪邊:如果AC x CD < 0,那麼A在CD左邊。

由於資料範圍為5000,可以用二分查詢。

程式碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdlib.h>
using namespace std;
typedef struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){}
}Vector;
Vector operator + (Vector A,Vector B){return Vector(A.x+B.x,A.y+B.y);}
Vector operator - (Point A,Point B){return Vector(A.x-B.x,A.y-B.y);}
Vector operator * (Vector A,double p){return Vector(A.x*p,A.y*p);}
Vector operator / (Vector A,double p){return Vector(A.x/p,A.y/p);}
bool operator < (const Point& a,const Point& b){return a.x<b.x || (a.x==b.x && a.y<b.y);}
const double eps = 1e-10;
int dcmp(double x)
{
    if(fabs(x) < eps) return 0; else return x < 0 ? -1 : 1;
}
bool operator == (const Point& a,const Point &b)
{
    return dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0;
}
double Dot(Vector A,Vector B){return A.x*B.x + A.y*B.y;}
double Length(Vector A){return sqrt(Dot(A,A));}
double Angle(Vector A,Vector B){return acos(Dot(A,B) / Length(A) / Length(B));}
double Cross(Vector A,Vector B){return A.x*B.y - A.y*B.x;}
double Area2(Point A,Point B,Point C){return Cross(B-A,C-A);}

int n,m;
double xx1,yy1,xx2,yy2;
int room[5005];
Point e[5005][2];
int Bifind(Point A,int L,int R)
{
    int mid=(L+R)/2;
    if(Cross(A-e[mid+1][1],e[mid+1][0]-e[mid+1][1])<0 && Cross(A-e[mid][1],e[mid][0]-e[mid][1])>0)
        return mid;
    else if(Cross(A-e[mid+1][1],e[mid+1][0]-e[mid+1][1])>0)
        return Bifind(A,mid+1,R);
    else return Bifind(A,L,mid);
}
int main()
{
    int flag=0;
    while(scanf("%d",&n) && n)
    {
        scanf("%d%lf%lf%lf%lf",&m,&xx1,&yy1,&xx2,&yy2);
        e[0][0]=Point(xx1,yy1);
        e[0][1]=Point(xx1,yy2);
        e[n+1][0]=Point(xx2,yy1);
        e[n+1][1]=Point(xx2,yy2);
        double u,l;
        for(int i=1;i<=n;i++)
        {
            scanf("%lf%lf",&u,&l);
            e[i][0]=Point(u,yy1);
            e[i][1]=Point(l,yy2);
        }
        memset(room,0,sizeof room);
        double xx,yy;
        for(int i=0;i<m;i++)
        {
            scanf("%lf%lf",&xx,&yy);
            room[Bifind(Point(xx,yy),0,n)]++;
        }
        if(flag) printf("\n");
        for(int i=0;i<=n;i++)
            printf("%d: %d\n",i,room[i]);
        flag=1;
    }
    return 0;
}