1. 程式人生 > >poj2104 K-th Number (主席樹入門題|模板題)

poj2104 K-th Number (主席樹入門題|模板題)

K-th Number
Time Limit: 20000MS Memory Limit: 65536K
Total Submissions: 48751 Accepted: 16447
Case Time Limit: 2000MS

Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.

Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).

Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.

Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6

3

題目大意:q次詢問,求區間(l,r)的第k小元素

思路:主席樹的最經典應用。

今天也是看了大牛的程式碼剛學的。

程式碼如下:

#include <map>
#include <set>
#include <cmath>
#include <queue>
#include <vector>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=1e5+10;
struct node
{
	int l,r,sum,lson,rson;
}tr[2000010];
int rt[maxn],A[maxn],B[maxn],cnt,pos;
void Buildtree(int l,int r,int& cur)
{
	cur=++cnt;
	tr[cur].l=l,tr[cur].r=r,tr[cur].sum=0;
	if(l==r)return;
	int mid=(l+r)>>1;
	Buildtree(l,mid,tr[cur].lson);
	Buildtree(mid+1,r,tr[cur].rson);
}
void Insert(int pre,int& cur)
{
	cur=++cnt;
	tr[cur]=tr[pre],tr[cur].sum=tr[cur].sum+1;
	if(tr[cur].l==tr[cur].r)return;
	int mid=(tr[cur].l+tr[cur].r)>>1;
	if(pos<=mid)Insert(tr[pre].lson,tr[cur].lson);
	else Insert(tr[pre].rson,tr[cur].rson);
}
int Query(int lqj,int rqj,int k)
{
	if(tr[rqj].lson==tr[rqj].rson)return B[tr[rqj].l];
	int cmp=tr[tr[rqj].lson].sum-tr[tr[lqj].lson].sum;
	if(cmp>=k)return Query(tr[lqj].lson,tr[rqj].lson,k);
	else return Query(tr[lqj].rson,tr[rqj].rson,k-cmp);
}
int main()
{
	int n,q,ql,qr,ans,key;
	scanf("%d%d",&n,&q);
	cnt=0;
	for(int i=1;i<=n;i++)scanf("%d",&A[i]),B[i]=A[i];
	sort(B+1,B+1+n);
	Buildtree(1,n,rt[0]);
	for(int i=1;i<=n;i++)pos=lower_bound(B+1,B+1+n,A[i])-B,Insert(rt[i-1],rt[i]);
	while(q--)scanf("%d%d%d",&ql,&qr,&key),ans=Query(rt[ql-1],rt[qr],key),printf("%d\n",ans);
}