1. 程式人生 > >[kuangbin帶你飛]專題一 簡單搜尋-B

[kuangbin帶你飛]專題一 簡單搜尋-B

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

ac程式碼,這題其實就是一個簡單的三維廣度優先搜尋演算法

#include"iostream"
#include"string.h"
#include"queue"
using namespace std;

int high,cur,lie;
char ai[100][100][100];
bool sign[100][100][100];
int fx[][3]={0,0,1,0,0,-1,0,1,0,0,-1,0,1,0,0,-1,0,0};

struct node{
    int x,y,z;
    int step;
};
node qi,zhou;

bool check(int a,int b,int c)
{
    if(a>=0&&a<high&&b>=0&&b<cur&&c>=0&&c<lie&&ai[a][b][c]!='#'&&!sign[a][b][c])
        return true;
    return false;
} 

void bfs()
{
    node mm,nn;
    sign[qi.x][qi.y][qi.z]=true;
    queue<node> jj;
    jj.push(qi);
    while(!jj.empty())
    {
        mm=jj.front();
        jj.pop();
        if(mm.x==zhou.x&&mm.y==zhou.y&&mm.z==zhou.z)
        {
            cout<<"Escaped in "<<mm.step<<" minute(s)."<<endl;
            return ;
        }
        for(int i=0;i<6;i++)
        {
            nn=mm;
            nn.x+=fx[i][0];
            nn.y+=fx[i][1];
            nn.z+=fx[i][2];
            if(check(nn.x,nn.y,nn.z))
            {
                //cout<<nn.x<<" "<<nn.y<<" "<<nn.z<<endl;
                sign[nn.x][nn.y][nn.z]=true;
                nn.step++;
                jj.push(nn);
            } 
        }
    } 
    cout<<"Trapped!"<<endl;
} 

int  main()
{
    while(cin>>high>>cur>>lie)
    {
        if(high==0&&cur==0&&lie==0)
            break;
        memset(sign,false,sizeof(sign));
        for(int i=0;i<high;i++)
        {
            for(int j=0;j<cur;j++)
            {
                cin>>ai[i][j];
                for(int k=0;k<lie;k++)
                {
                    if(ai[i][j][k]=='S')
                    {
                        qi.x=i;
                        qi.y=j;
                        qi.z=k;
                        qi.step=0;
                    }
                    else if(ai[i][j][k]=='E')
                    {
                        zhou.x=i;
                        zhou.y=j;
                        zhou.z=k;
                    }
                }
            }
        }
        bfs();
    }
    return 0;
}