1. 程式人生 > >POJ 2367 Genealogical tree(系譜圖,拓撲排序)

POJ 2367 Genealogical tree(系譜圖,拓撲排序)

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4646 Accepted: 3085 Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural. 
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal. 
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source


題意:

火星人的種族關係混亂,即使有十個父親,一百個孩子也不為過。(最起碼是人,這出題人是不是反倫理昂!!)

給定我們一些資料,排序輸出例如 :

a b c d e 表示 b 是 a 的孩子;c 是 d 的孩子.....就是家族系譜圖吧。

鍵入資料提示:
人口數目 n

第 1 個人的孩子 (鍵入 0 結束)

第 2 個人的孩子 (鍵入 0 結束)

第 n-1 個人的孩子 (鍵入 0 結束)

第 n 人的孩子 (鍵入 0 結束)

思路:

理解題意,看懂測試資料可以試著敲一下程式碼。
簡單的拓撲排序,這裡用二維陣列方式來實現,也可以嘗試用佇列的方式。

程式碼:

實現方式:二維陣列

#include<stdio.h>
#include<string.h>
const int MYDD=1103;

int indegree[MYDD];
int map[113][113];
int ans[MYDD];//記錄排序順序
void TopoSort(int x) {
	int now,dd=1;// now 當前選中的節點; dd ans[]陣列的大小
	for(int j=1; j<=x; j++) {
		for(int i=1; i<=x; i++) {
			if(!indegree[i]) {
				now=i;
				break;//入度為 0 即前驅
			}
		}
		ans[dd++]=now;
		indegree[now]=-1;//標記前驅數量為 -1
		for(int i=1; i<=x; i++)//當前節點的後繼節點入度 -1
			if(map[now][i])     indegree[i]--;
	}
}

int main() {
	int n;
	scanf("%d",&n);
	memset(indegree,0,sizeof(indegree));
	memset(map,0,sizeof(map));
	for(int j=1; j<=n; j++) {
		int v;
		scanf("%d",&v);
		while(v) {
			map[j][v]=1;
			indegree[v]++;//入度的增加
			scanf("%d",&v);
		}
	}

	TopoSort(n);//拓撲排序

	for(int j=1; j<=n; j++)	printf("%d ",ans[j]);
	return 0;
}


後:

********************