1. 程式人生 > >HDU 1049 青蛙爬進 (水題_模擬)

HDU 1049 青蛙爬進 (水題_模擬)

Problem Description An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.

Input There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input 10 2 1 20 3 1 0 0 0
Sample Output 17 19

n為井深(m),u為上升的速度(m/s),d為下滑的速度 (m/s)

#include<iostream>
#include<cstdio> 
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int n,u,d,temp;
	int ans;
	while(cin>>n>>u>>d) {
		temp=0;
		ans=0;
		if(n==0 && u==0 && d==0) break;
		while(1){
			ans++;
			temp+=u;
			if(temp>=n) break;
			ans++;
			temp-=d;
		}
		cout<<ans<<endl;
	}
	return 0;
}