1. 程式人生 > >ZOJ 1114-Chocolate (概率DP)

ZOJ 1114-Chocolate (概率DP)

Problem Description

In 2100, ACM chocolate will be one of the favorite foods in the world.
"Green, orange, brown, red…", colorful sugar-coated shell maybe is the most attractive feature of ACM chocolate. How many colors have you ever seen? Nowadays, it's said that the ACM chooses from a palette of twenty-four colors to paint their delicious candy bits.

One day, Sandy played a game on a big package of ACM chocolates which contains five colors (green, orange, brown, red and yellow). Each time he took one chocolate from the package and placed it on the table. If there were two chocolates of the same color on the table, he ate both of them. He found a quite interesting thing that in most of the time there were always 2 or 3 chocolates on the table.

Now, here comes the problem, if there are C colors of ACM chocolates in the package (colors are distributed evenly), after N chocolates are taken from the package, what's the probability that there is exactly M chocolates on the table? Would you please write a program to figure it out?

Input


The input file for this problem contains several test cases, one per line.

For each case, there are three non-negative integers: C (C <= 100), N and M (N, M <= 1000000).

The input is terminated by a line containing a single zero.

Output


The output should be one real number per line, shows the probability for each case, round to three decimal places.

Sample Input

5 100 20

Sample Output

0.625

Source

2002 ACM/ICPC Beijing 

給你c,n,m,表示有c種顏色的巧克力,每種顏色的巧克力有無數個,每次隨機取一個放在桌子上,當有兩個巧克力的顏色相同的話就會將這兩個巧克力吃掉,問你在取n個巧克力後,桌子上正好有m個巧克力的概率是多少?

題解:設dp[i][j]:表示取完i個桌子上能留下j個的概率,然後直接進行dp即可,因為顏色數只有100這麼大,所以當取的個數足夠多時,概率會趨近於一個極限值,因此我們讓n在很大時取一個合適的值即可。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double f[1005][105];
int n,m,c;
int main(void)
{
	while(scanf("%d",&c),c!=0)
	{
		scanf("%d%d",&n,&m);
		if(n==0 && m==0)
		{
			printf("1.000\n");
			continue;
		}
		if(m>c || m>n || (n+m)%2)
		{
			printf("0.000\n");
			continue;
		}
		if(n>1000) n=1000+(n%2!=0);
		memset(f,0,sizeof(f));f[1][1]=1;
		for(int i=2;i<=n;i++)
			for(int j=0;j<=min(i,c);j++)
			{
				if(i+j&1)
				{
					f[i][j]=0;
					continue;
				}
				if(j>0) f[i][j]+=f[i-1][j-1]*(1-(double)(j-1)/c);
				if(j<i) f[i][j]+=f[i-1][j+1]*((double)(j+1)/c);
			}
		printf("%.3f\n",f[n][m]);
	}
	return 0;
}