1. 程式人生 > >POJ 1157 LITTLE SHOP OF FLOWERS(DP)

POJ 1157 LITTLE SHOP OF FLOWERS(DP)

Description

You want to arrange the window of your flower shop in a most pleasant way. You have F bunches of flowers, each being of a different kind, and at least as many vases ordered in a row. The vases are glued onto the shelf and are numbered consecutively 1 through V, where V is the number of vases, from left to right so that the vase 1 is the leftmost, and the vase V is the rightmost vase. The bunches are moveable and are uniquely identified by integers between 1 and F. These id-numbers have a significance: They determine the required order of appearance of the flower bunches in the row of vases so that the bunch i must be in a vase to the left of the vase containing bunch j whenever i < j. Suppose, for example, you have bunch of azaleas (id-number=1), a bunch of begonias (id-number=2) and a bunch of carnations (id-number=3). Now, all the bunches must be put into the vases keeping their id-numbers in order. The bunch of azaleas must be in a vase to the left of begonias, and the bunch of begonias must be in a vase to the left of carnations. If there are more vases than bunches of flowers then the excess will be left empty. A vase can hold only one bunch of flowers. 

Each vase has a distinct characteristic (just like flowers do). Hence, putting a bunch of flowers in a vase results in a certain aesthetic value, expressed by an integer. The aesthetic values are presented in a table as shown below. Leaving a vase empty has an aesthetic value of 0. 

V A S E S

1

2

3

4

5

Bunches

1 (azaleas)

7 23 -5 -24 16

2 (begonias)

5 21 -4 10 23

3 (carnations)

-21

5 -4 -20 20

According to the table, azaleas, for example, would look great in vase 2, but they would look awful in vase 4. 

To achieve the most pleasant effect you have to maximize the sum of aesthetic values for the arrangement while keeping the required ordering of the flowers. If more than one arrangement has the maximal sum value, any one of them will be acceptable. You have to produce exactly one arrangement. 

Input

  • The first line contains two numbers: FV
  • The following F lines: Each of these lines contains V integers, so that Aij is given as the  jth number on the (i+1)st line of the input file. 

  • 1 <= F <= 100 where F is the number of the bunches of flowers. The bunches are numbered 1 through F. 
  • F <= V <= 100 where V is the number of vases. 
  • -50 <= Aij <= 50 where Aij is the aesthetic value obtained by putting the flower bunch i into the vase j. 

Output

The first line will contain the sum of aesthetic values for your arrangement. 

Sample Input

3 5
7 23 -5 -24 16
5 21 -4 10 23
-21 5 -4 -20 20

Sample Output

53
分析:類似於最大子串和。令dp[i][j]=已經放入i~F束花,且第i束花放在第j個花瓶的最大價值。狀態轉移如下
dp[i][j]=A[i][j]+max{dp[i+1][j+1],dp[i+1][j+2],...,dp[i+1][V-F+i+1]}
複雜度為O(V^2*F)
優化:注意到在狀態轉移方程中的max部分做了重複計算,因此可以記錄之前的結果。令B[i][j]=
max{dp[i][j],dp[i][j+1],...,dp[i][V-F+i]},則
(1)dp[i][j]=A[i][j]+B[i+1][j+1]
(2)B[i][j]=max{dp[i][j],B[i][j+1]}
在計算時注意邊界。複雜度為O(V*F)
程式碼如下。
/*
	PROG: POJ1157
	PROB: DP, O(N^2)
*/

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

#define DEBUG 1
#define LOG(...) do { if (DEBUG) fprintf(stderr, __VA_ARGS__); } while(0)

#define MAXN 105
int A[MAXN][MAXN], B[MAXN][MAXN], dp[MAXN][MAXN];
int main(void) {
	int F, V; scanf("%d%d", &F, &V);
	for (int i = 0; i < F; ++i)
		for (int j = 0; j < V; ++j)
			scanf("%d", &(A[i][j]));
	dp[F-1][V-1] = B[F-1][V-1] = A[F-1][V-1];
	for (int j = V-2; j >= 0; --j) {
		dp[F-1][j] = A[F-1][j];
		B[F-1][j] = max(dp[F-1][j], B[F-1][j+1]);
	}
	for (int i = F-2; i >= 0; --i) {
		dp[i][V-F+i] = B[i][V-F+i] = A[i][V-F+i]+B[i+1][V-F+i+1];
		for (int j = V-F+i-1; j >= 0; --j) {
			dp[i][j] = A[i][j]+B[i+1][j+1];
			B[i][j] = max(dp[i][j], B[i][j+1]);
		}
	}
	printf("%d\n", B[0][0]);
	return 0;
}