1. 程式人生 > >【POJ 2387】Til the Cows Come Home(Dij最短路)

【POJ 2387】Til the Cows Come Home(Dij最短路)

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

  • Line 1: Two integers: T and N

  • Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

  • Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

題目大意

問你從N到1的最短路徑

思路

Dij模版題,要考慮有重邊的問題,在輸入的時候如果有重邊只選擇最短的一條邊。

程式碼

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>


using namespace std;
const int maxn=1000+5;
const int INF=0x3fffff;

int t,n,s,e,v;
int map[maxn][maxn];
int dis[maxn],vis[maxn];

void dij(int s)
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=INF;
    }
    dis[s]=0;
    for(int i=1;i<=n;i++)
    {
        int pos=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&(pos==-1||dis[j]<dis[pos]))
            {
                pos=j;
            }
        }
        vis[pos]=1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&(dis[j]>dis[pos]+map[pos][j]))
            {
                dis[j]=map[pos][j]+dis[pos];
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&t,&n))
    {
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                map[i][j]=map[j][i]=INF;
            }
        }
        for(int i=1;i<=t;i++)
        {
            scanf("%d %d %d",&s,&e,&v);
            if(map[s][e]==INF) map[s][e]=map[e][s]=v;
            else if(map[s][e]>v) map[s][e]=map[e][s]=v;
        }
        dij(1);
        printf("%d\n",dis[n]);
    }
    return 0;
}