1. 程式人生 > >Tram (最短路練習模板題)

Tram (最短路練習模板題)

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 
Input The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 
Output The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1". Sample Input
3 2 1
2 2 3
2 3 1
2 1 2
Sample Output

0

floyd模板:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<queue>
#define INF 1000000
using namespace std;
int n,f,l;
int w[103][103];
void floyed()
{
    for(int k=1; k<=n; k++)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
            {
                w[i][j]=min(w[i][j],w[i][k]+w[k][j]);
            }
        }
    }
    if(w[f][l]<INF)
        printf("%d\n",w[f][l]);
    else
        printf("-1\n");
}
int main()
{
    while(~scanf("%d%d%d",&n,&f,&l))
    {
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=n;j++)
           {
               w[i][j]=(i==j?0:INF);
           }
       }
        int m;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&m);
            for(int j=1; j<=m; j++)
            {
                int x;
                scanf("%d",&x);
                if(j==1)
                    w[i][x]=0;
                else
                    w[i][x]=1;
            }
        }
        floyed();
    }
}