1. 程式人生 > >大數a+b【大數】

大數a+b【大數】

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

題意:大數a+b;

#include<stdio.h>
#include<string.h>
char a[1000+13],b[1000+13];
int c[1000+10],d[1000+13],e[1000+13],f[1000+13];
int max(int a,int b)
{
	if(a>b) return a;
	return b;
}
int main()
{
	int i,t,m,n,x,len1,len2,len3,j=0;
	scanf("%d\n",&t);
	int k=t;
	while(t--)
	{
		if(k>t+1)
		{
			printf("\n");
		}
		x=0;
		memset(e,0,sizeof(e));
		memset(c,0,sizeof(c));
		memset(d,0,sizeof(d));
		scanf("%s %s",a,b);
		len1=strlen(a);
		len2=strlen(b);
		m=0;n=0;
		for(i=len1-1;i>=0;i--)
		{
			c[n++]=a[i]-'0';
	    }
		for(i=len2-1;i>=0;i--)
		{
			d[m++]=b[i]-'0';
		}
		for(i = 0; i < max(len1, len2) + 1; i++)
	    {
            e[i] = 0;
        }
		for(i=0;i<max(len1,len2)+1;i++)
		{
			e[i] = c[i] + d[i] + e[i];
            if(e[i] >= 10)
			{
                e[i]-= 10;
                e[i + 1]++;
            }
		}
		for(i=max(len1,len2)+1;i>=0;i--)
		{
			x++;
			if(e[i]!=0)
			{
				break;
			}
		}
		j++;
		printf("Case %d:\n",j);
		printf("%s + %s = ",a,b);
		for(i=max(len1,len2)-x+2;i>=0;i--)
		{
			printf("%d",e[i]);
		}
		printf("\n");
	}
	return 0;
}