1. 程式人生 > >Poj 2976 Dropping tests(01分數規劃 牛頓迭代)

Poj 2976 Dropping tests(01分數規劃 牛頓迭代)

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Description
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .
Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.
Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.
Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
Sample Output
83
100
Hint
To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).
Source
Stanford Local 2005

/*
裸的01分數規劃問題.
令∑a[i]/∑b[i]=ans. 
則∑a[i]-∑b[i]*ans=0. 
二分一個ans.
然後用a[i]-b[i]*ans取前k大檢驗.
只能去感性的認識orz...
並不會證明.. 
*/
#include<iostream>
#include<cstdio>
#include<algorithm>
#define eps 1e-7
#define MAXN 1001
using namespace std;
double ans,a[MAXN],b[MAXN],sum,tmp[MAXN];
int n,m,k;
bool
check(double x) { double tot=0; for(int i=1;i<=n;i++) tmp[i]=a[i]-x*b[i]; sort(tmp+1,tmp+n+1,greater<double>()); for(int i=1;i<=n-k;i++) tot+=tmp[i]; if(tot>=0) return true; else return false; } void slove() { double l=0,r=1e4,mid; while(l<=r) { mid=(l+r)/2.0
; if(check(mid)) l=mid+eps,ans=mid; else r=mid-eps; } printf("%.0f\n",ans*100); return ; } int main() { while(scanf("%d%d",&n,&k)) { if(!n&&!k) break; sum=ans=0; for(int i=1;i<=n;i++) scanf("%lf",&a[i]); for(int i=1;i<=n;i++) scanf("%lf",&b[i]); slove(); } return 0; }
/*
發現這題牛頓迭代可做吖.
網上的題解都是二分01規劃的.
我就寫個牛頓迭代的吧orz(雖然二分的寫過).
先選一個估計值s0.
我們能保證這個答案是單調的.
假設上次迭代的ans為s1,
則存在n-k個元素使s1=∑(ai/bi),
變形可得到∑ai-s2*∑bi=0,
令ans[i]=a[i]-b[i]*s0.
取前n-k大統計一個答案.
可知必存在n-k個元素使∑ansi=∑ai-s1*∑bi=0,
所以當我們按ans排序並取前n-k個元素作為求其∑ans時,
∑ansi顯然是>=0的,
然後s1=(∑ai-∑ansi)/∑bi)<=(∑ai/∑bi)=s2(i<=n-k).
即此迭代過程是收斂的,當等號成立時,s即為答案.
有些地方還是有點想不通畢竟弱吖orz. 
*/
#include<cstdio>
#include<algorithm>
#include<cmath>
#define MAXN 1001
#define eps 1e-7
using namespace std;
double ans,sum,tmp[MAXN];
int n,m,k;
struct data{double a,b,ans;}s[MAXN];
bool cmp(const data &x,const data &y)
{
    return x.ans>y.ans;
}
void slove()
{
    double suma=0,sumb=0,s0=0,s1=0;
    for(int i=1;i<=k;i++) suma+=s[i].a,sumb+=s[i].b;
    s0=suma/sumb;
    while(abs(s0-s1)>eps)
    {
        s1=s0;suma=sumb=0;
        for(int i=1;i<=n;i++) s[i].ans=s[i].a-s[i].b*s0;
        sort(s+1,s+n+1,cmp);
        for(int i=1;i<=k;i++) suma+=s[i].a,sumb+=s[i].b;
        s0=suma/sumb;
    }
    printf("%.0f\n",s0*100);
    return ;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(!n&&!k) break;
        sum=ans=0;k=n-k;
        for(int i=1;i<=n;i++) scanf("%lf",&s[i].a);
        for(int i=1;i<=n;i++) scanf("%lf",&s[i].b);
        slove();
    }
    return 0;
}