1. 程式人生 > >【POJ 2823】Sliding Window(單調佇列)

【POJ 2823】Sliding Window(單調佇列)

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 56138 Accepted: 16137
Case Time Limit: 5000MS

Description

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k
 numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n
 integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

Source

【題解】【單調佇列模板題】
#include<cstdio>
#include<cstring>
using namespace std;
int a[1000010],p[1000010],h,t,n,k;
void pushmin(int i)
{
    while(h!=t&&a[p[t]]>a[i]) t--;
    t++; p[t]=i;
    return;
}//維護遞增的單調佇列 
void pushmax(int i)
{
    while(h!=t&&a[p[t]]<a[i]) t--;
    t++; p[t]=i;
    return;
}//維護遞減的單調佇列 
int main()
{
    int i,j;
    scanf("%d%d",&n,&k);
    for(i=1;i<=n;i++) scanf("%d",&a[i]);
    h=t=0;
    for(i=1;i<=k;i++) pushmin(i);
    printf("%d ",a[p[h+1]]);
    for(i=k+1;i<=n;i++)
     {
        while(h!=t&&p[h+1]<=i-k) h++;
        pushmin(i);
        printf("%d ",a[p[h+1]]);
    }//維護最小值的單調佇列 
    memset(p,0,sizeof(p));
    h=t=0;
    for(i=1;i<=k;i++) pushmax(i);
    printf("\n%d ",a[p[h+1]]);
    for(i=k+1;i<=n;i++)
     {
        while(h!=t&&p[h+1]<=i-k) h++;
        pushmax(i);
        printf("%d ",a[p[h+1]]);
    }//維護最大值的單調佇列 
    return 0;
}//只是一個裸裸的單調佇列(好吧,其實我是剛學的)