1. 程式人生 > >HDU Joseph【數學&&約瑟夫環】

HDU Joseph【數學&&約瑟夫環】

Joseph

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 2118 Accepted Submission(s): 1285
Problem Description The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.

Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.

Input The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.

Output The output file will consist of separate lines containing m corresponding to k in the input file.

Sample Input 3 4 0
Sample Output 5 30

以前做過一次約瑟夫環問題,不過沒太明白當時大神的最優程式碼,這一次又見到了類似的題,只能無腦模擬了,不過暴力模擬,很果斷的TLE了.......

找大神們的解析,加深了自己的理解,不過自己還是不太明白,貌似是,利用數學技巧,動態處理了,簡化了很多東西...(自己說不明白了)

然後就是打表處理了.....

#include<stdio.h> 
#include<string.h>
bool joseph(int k,int m)
{
	int bg=0,ed=k-1,tp;
	for(int n=2*k;n>k;--n)
	{
		tp=(m-1)%n;
		if(tp>=bg&&tp<=ed)
		{
			return 0;
		}
		bg=(bg-m%n+n)%n;ed=(ed-m%n+n)%n;
		//bg=((bg-m)%n+n)%n;ed=((ed-m)%n+n)%n;//同餘還是理解的不夠
	}
	return 1;
}
int main()
{
	int n,y[20]={0};
	for(int i=1;i<14;++i)
	{
		int j=i+1;
		while(1)
		{
			if(joseph(i,j))
			{
				y[i]=j;
				break; 
			}
			++j;
		} 
	}
	//freopen("shuju.txt","r",stdin);
	while(scanf("%d",&n),n)
	{
		printf("%d\n",y[n]);
	}
	return 0;
}