1. 程式人生 > >Poj.2689 Prime Distance【素數篩選】 2015/11/13

Poj.2689 Prime Distance【素數篩選】 2015/11/13

Prime Distance
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 14884 Accepted: 3949

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source

區間素數篩選,找出區間內相鄰素數距離最小與最大的兩組數,若有多組,取最靠前的一組
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>

using namespace std;

#define maxn 1000000+10

int prime[100010+1],prime2[maxn+1];
bool notprime[maxn+1];

void get(){
    memset(notprime,false,sizeof(notprime));
    prime[0] = 0;
    for( int i = 2 ; i <= 100010 ; ++i ){
        if( !notprime[i] ){
            prime[++prime[0]] = i;
            for( int j = 2 ; i*j <= 100010 ; ++j ){
                notprime[j*i] = true;
            }
        }
    }
}

void check(int L,int R){
    if( L < 2 ) L = 2;
    memset(notprime,false,sizeof(notprime));
    for( int i = 1 ; i <= prime[0] && (long long)prime[i]*prime[i] <= R ; ++i ){
        int s = L/prime[i]+(L%prime[i]>0);
        if( s == 1 ) s = 2;
        for( int j = s ; (long long)j*prime[i] <= R ; ++j ){
            if( (long long)j*prime[i] >= L )
                notprime[j*prime[i]-L] = true;
        }
    }
    prime2[0] = 0;
    for( int i = 0 ; i <= R-L ; ++i ){
        if( !notprime[i] )
            prime2[++prime2[0]] = i+L;
    }
}

int main(){
    int L,U;
    get();
    while( ~scanf("%d %d",&L,&U) ){
        check(L,U);
        if( prime2[0] < 2 ) {
            printf("There are no adjacent primes.\n");
            continue;
        }
        int a,b,c,d,ab=maxn,cd=0;
        for( int i = 2 ; i <= prime2[0] ; ++i ){
            if( ab > prime2[i]-prime2[i-1] ){
                a = prime2[i-1];
                b = prime2[i];
                ab = b - a;
            }
            if( cd < prime2[i]-prime2[i-1] ){
                c = prime2[i-1];
                d = prime2[i];
                cd = d - c;
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n",a,b,c,d);
    }
    return 0;
}