1. 程式人生 > >1140 面向物件程式設計上機練習一(函式過載)

1140 面向物件程式設計上機練習一(函式過載)

面向物件程式設計上機練習一(函式過載)

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

利用陣列和函式過載求5個數最大值(分別考慮整數、單精度、長整數的情況)。

Input

分別輸入5個int型整數、5個float 型實數、5個long型正整數。

Output

分別輸出5個int型整數的最大值、5個float 型實數的最大值、5個long型正整數的最大值。

Example Input

11 22 666 44 55
11.11 22.22 33.33 888.88 55.55
1234567 222222 333333 444444 555555

Example Output

666
888.88
1234567
#include <iostream>
using namespace std;

int main()
{
    int t = 5;
    int x,max1 = 0;
    float y,max2 = 0;
    long long int z,max3 = 0;
    while(t--)
    {
        cin >> x;
        max1 = max(max1,x);
    }
    t = 5;
    while(t--)
    {
        cin >> y;
        max2 = max(max2,y);
    }
    t = 5;
    while(t--)
    {
        cin >> z;
        max3 = max(max3,z);
    }
    cout << max1 << endl;
    cout << max2 << endl;
    cout << max3 << endl;
    return 0;
}