1. 程式人生 > >What day is that day?(zoj水題)

What day is that day?(zoj水題)

What day is that day?
Time Limit: 2 Seconds      Memory Limit: 65536 KB

It's Saturday today, what day is it after 11 + 22 + 33 + ... + NN days?

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

There is only one line containing one integer N

 (1 <= N <= 1000000000).

Output

For each test case, output one string indicating the day of week.

Sample Input

2
1
2

Sample Output

Sunday
Thursday

Hint

A week consists of Sunday, Monday, Tuesday, Wednesday, Thursday, Friday and Saturday.

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;
int a[300];
char str[10][10]={"Saturday","Sunday","Monday", "Tuesday", "Wednesday", "Thursday", "Friday"};
int MUL(int n)
{
    int sum=1;
    for(int i=1; i<=n; i++)
    {
        sum*=n;
        sum%=7;
    }
    return sum;
}
int main()
{
    int t,n;
    a[0]=0;
    for(int i=1; i<=294; i++)
    {
        a[i]=a[i-1]+MUL(i);
        a[i]%=7;
    }
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        n%=294;
        printf("%s\n",str[a[n]]);
    }

    return 0;
}