1. 程式人生 > >Stars (HDU 1541)——樹狀陣列實現

Stars (HDU 1541)——樹狀陣列實現

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11904    Accepted Submission(s): 4725


Problem Description Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
Output The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input5 1 1 5 1 7 1 3 3 5 5
Sample Output1 2 1 1 0 Answer
#include <iostream>
#define MAX 1000000
using namespace std;
int L[MAX];
int C[MAX];
int lowbit(int x)//位運算
{
    return x&(-x);
}
int getsum(int x)//查詢
{
    int res=0;
    while(x>0)
    {
        res+=C[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int v)//改變
{
    while(x<MAX)
    {
        C[x]+=v;
        x+=lowbit(x);
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(C,0,sizeof(C));//初始化陣列
        memset(L,0,sizeof(L));//初始化陣列
        for(int i=0;i<n;i++)
        {
            int x,y;
            cin>>x>>y;
            x++;//避免x=0的點
            L[getsum(x)]++;//等級為getsum(x)的點加一
            add(x,1);
        }
        for(i=0;i<n;i++)
            cout<<L[i]<<endl;
    }
    return 0;
}