1. 程式人生 > >POJ 1006:Biorhythms 中國剩餘定理

POJ 1006:Biorhythms 中國剩餘定理

Biorhythms
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 121194 Accepted: 38157

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

題意是在人的一生中有三種生物節律,身體、情緒和智力,每一個情緒都有相應的週期,到了這個週期點這個人的這個方面就變得特別屌。

現在給你這三個的週期為23 28 33。這是固定的了。

然後給你上一個三個週期的巔峰時刻是p e i,問從d時間開始還有多久的N天,三個週期一次一起到達巔峰。

列公式是N+d = p+23*N1 = e+28*N2 = i+33*N3

N1,N2,N3是整數我們不用管,也沒要求。要求的是N。

再轉化一下就是求一個數最小的S,這個數S除以23餘p,除以28餘e,除以33餘i。當然最後要求的那個N只需S-d就好了。

又一次漲姿勢了。。。中國剩餘定理。

首先求滿足  除以23餘1,整除28,整除33的三個條件的最小數,發現是5544。

然後求滿足  除以28餘1,整除23,整除33的三個條件的最小數,是14421。

然後求滿足  除以33餘1,整除23,整除28的三個條件的最小數,是1288。

然後5544*p+14421*e+1288*i就一定是三個週期的下一個巔峰了,只不過不一定是最小值。

這裡解釋一下上面那麼做的原因是什麼:

1.一個數A除以23餘1,B除以23整除,那麼(A+B)除以23依舊是餘1的。即一個數加上整除x的數,其除以x的餘數是不變的。

所以對於23來說,A+B+C餘數還是1,因為B和C是整除23的。

對於28來說,A+B+C餘數還是1,因為A和C是整除28的。

對於33來說,A+B+C餘數還是1,因為A和B是整除33的。

2.A除以23餘1,A*c除以23就餘c*1,即餘c了。

所以得到結論就是5544*p除以23就餘p,除以28整除,除以33整除

14421*e除以28餘e,除以23整除,除以33整除

1288*i除以33餘i,除以23整除,除以28整除

所以這三個相加就滿足條件嘍,只是不一定是最小值,如何求最小值%lcm(23,28,33)即可。

程式碼:

#include <iostream>
#include <algorithm>
#include <cmath>
#include <vector>
#include <string>
#include <cstring>
#pragma warning(disable:4996)
using namespace std;

int main()
{
	int a,b,c,d,j=1;
	while(cin>>a>>b>>c>>d)
	{
		if(a+b+c+d==-4)
			break;
		cout<<"Case "<<j;
		j++;
		cout<<": the next triple peak occurs in ";
		int temp=(5544*a+14421*b+1288*c-d+21252)%21252;
		if(temp==0)
		{
			cout<<21252;
		}
		else
			cout<<temp;
		cout<<" days."<<endl;
	}
	return 0;
}