1. 程式人生 > >2492Ping pong(樹狀陣列|權值線段樹)

2492Ping pong(樹狀陣列|權值線段樹)

Ping pong

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5424 Accepted Submission(s): 2020

Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee’s house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <= ai <= 100000, i = 1 … N).

Output
For each test case, output a single line contains an integer, the total number of different games.

Sample Input
1
3 1 2 3

Sample Output
1

Source
2008 Asia Regional Beijing

Recommend
gaojie

題意:

問有多少個三元組滿足i

a[i]<=a[j]<=a[k]||a[i]>=a[k]>=a[j]

那就前後開樹狀陣列或者線段樹維護資訊即可。

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long LL;
const int maxn=1e5+5;

int S[maxn],T[maxn],n,a[maxn];

inline void add(int *T,int x,int val)
{
  for(;x<=100000;x+=x&-x)T[x]+=val;
}

inline LL sum(int *T,int x)
{
  LL ans=0;
  for(;x;x-=x&-x)ans+=T[x];
  return ans;
}

int main()
{
  int t;
  scanf("%d",&t); 
  while(t--)
  {
    scanf("%d",&n);
    for(int i=1;i<=n;++i)scanf("%d",a+i);
    memset(S,0,sizeof(S));
    memset(T,0,sizeof(T));
    for(int i=1;i<=n;++i)add(T,a[i],1);
    LL ans=0;
    for(int i=1;i<=n;++i)
    {
      add(T,a[i],-1);
      ans+=sum(S,a[i])*(n-i-sum(T,a[i]-1));
      ans+=(i-1-sum(S,a[i]-1))*sum(T,a[i]);
      add(S,a[i],+1);
    }
    printf("%lld\n",ans);
  }
  return 0;
}