1. 程式人生 > >HDOJ 題目2602 Bone Collector(動態規劃,01揹包)

HDOJ 題目2602 Bone Collector(動態規劃,01揹包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29252    Accepted Submission(s): 11970


Problem Description Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


Input The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
Output One integer per line representing the maximum of the total value (this number will be less than 231
).
Sample Input 1 5 10 1 2 3 4 5 5 4 3 2 1
Sample Output 14
Author Teddy
Source  思路:純01揹包,模板就夠 ac程式碼
#include<stdio.h>
#include<string.h>
int maxx(int a,int b)
{
	if(a>b)
		return a;
	else
		return b;
}
int main()
{
	int v[100000],w[100000],i,j,n,m,t;
	int dp[2000];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		memset(dp,0,sizeof(dp));
		for(i=0;i<n;i++)
			scanf("%d",&v[i]);
		for(i=0;i<n;i++)
			scanf("%d",&w[i]);
		for(i=0;i<n;i++)
			for(j=m;j>=w[i];j--)
			{
				dp[j]=maxx(dp[j],dp[j-w[i]]+v[i]);
			}
		printf("%d\n",dp[m]);
	}
}