1. 程式人生 > >【HDOJ】2015ACM長春網路賽 Alisha’s Party【優先順序佇列應用】

【HDOJ】2015ACM長春網路賽 Alisha’s Party【優先順序佇列應用】

Alisha’s Party

Time Limit: 3000/2000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 7510    Accepted Submission(s): 1745

Problem Description

Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

Input

The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank. Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

Output

For each test case, output the corresponding name of Alisha’s query, separated by a space.

Sample Input

1 5 2 3 Sorey 3 Rose 3 Maltran 3 Lailah 5 Mikleo 6 1 1 4 2 1 2 3

Sample Output

Sorey Lailah Rose

Source

思路:利用優先順序模擬即可。但需要注意  詢問和 第幾個人進來的時候開門  這個順序不一定是按照順序給出的。需要排序一下。

註釋掉的程式碼是我一開始沒有考慮排序的時候用的。

#include<iostream>
#include<queue>
#include<string>
#include<algorithm>
using namespace std;
const int maxn=150005;
class Node{
	public:
		string name;
		int v;
		int pos;
		Node(){
		}
		Node(string nn,int vv,int pp){
			v=vv;
			name=nn;
			pos=pp;
		}
		friend bool operator< (Node n1,Node n2){
			if(n1.v!=n2.v)
			return n1.v<n2.v;
			return n1.pos>n2.pos;
		}
};
class B{
	public:
		int a,b;
		bool operator<(B& bb){
			return a<bb.a;
		}
};


Node arr[maxn];int arrsize=0;
int brr[maxn][2];int brrsize=0;int p1=0;//第幾次 
B brr2[maxn];
string ansstr[maxn];
int crr[101];int crrsize=0;int p2=0;
string ans[maxn];int anssize=0;
int as=0;//代表現在進入的數量 


int main(){
	std::ios::sync_with_stdio(false);
    std::cin.tie(0); 
	int T;cin>>T;
	while(T--){
		//初始化
		p1=p2=as=0; 
		
		//準備客人的行程表 
		cin>>arrsize>>brrsize>>crrsize;
		anssize=crrsize;
		for(int i=0;i<arrsize;i++){
			cin>>arr[i].name>>arr[i].v;
			arr[i].pos=i;
		}		
		for(int i=0;i<brrsize;i++){
			cin>>brr2[i].a>>brr2[i].b;
		}brr[brrsize][0]=-1;
		sort(brr2,brr2+brrsize);
		for(int i=0;i<brrsize;i++){
			brr[i][0]=brr2[i].a;
			brr[i][1]=brr2[i].b;
		}brr[brrsize][0]=-1;
		
		
		
		
		for(int i=0;i<crrsize;i++){
			cin>>crr[i];
		}crr[crrsize]=-1;
		//準備城堡的大廳 
		priority_queue<Node>pq;
		
		//來客了,姑娘們出來接客了 
		for(int i=0;i<arrsize;i++){
			pq.push(arr[i]);			
			if(i+1==brr[p1][0]){//該開門了 
				//客人進門
				int p=brr[p1][1];//應該進入的人數 
				while(p--&&!pq.empty()){
					Node top=pq.top();
					pq.pop();
					as++;
					ansstr[as]=top.name;
//					if(as==crr[p2]){//對進入的特殊使用者進行記錄 
//						ans[p2]=top.name;
//						p2++;
//					}
				}
				p1++;//準備開下一個門 
			}
		}
		//最後開一次門
		while(!pq.empty()) {
			Node top=pq.top();
			pq.pop();
			as++;ansstr[as]=top.name;
//			if(as==crr[p2]){//對特殊進入的使用者進行記錄 
//				ans[p2]=top.name;
//				p2++;
//			}
		}
		bool flag=true;
		for(int i=0;i<anssize;i++){
			if(flag)cout<<ansstr[crr[i]];
			else cout<<" "<<ansstr[crr[i]];
			flag=false;
		}cout<<endl;
//		for(int i=0;i<anssize;i++){
//			if(flag) cout<<ans[i];
//			else cout<<" "<<ans[i];
//			flag=false;
//		}cout<<endl;
	}
	return 0;
}