1. 程式人生 > >hdu1002 大數加法(java)

hdu1002 大數加法(java)

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 409774    Accepted Submission(s): 79404


Problem DescriptionI have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input2 1 2 112233445566778899 998877665544332211
Sample OutputCase 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
AuthorIgnatius.L
RecommendWe have carefully selected several similar problems for you:  
1000
 1001 1004 1003 1008 
import java.math.BigInteger;
import java.util.Scanner;
public class Main {

    public static void main(String[] args) {
		Scanner s=new Scanner(System.in);
		int k=1;
		int n=s.nextInt();
		for(int i=0;i<n;i++)
		{
			String str=s.next();
			BigInteger big=new BigInteger(str);
			String str1=s.next();
			System.out.printf("Case %d:",k++);
			System.out.println();
			System.out.print(str+" + "+str1+" = ");
			System.out.println(""+big.add(new BigInteger(str1)));
			if(i<n-1)
			System.out.println();
		}
		/*s.close();
		s1.close();*/
	}
}