1. 程式人生 > >poj 1276 Cash Machine(多重背包)

poj 1276 Cash Machine(多重背包)

algorithm 種類型 ted currency mbo 現在 mina script define

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350

633 4 500 30 6 100 1 5 0 1

735 0

0 3 10 100 10 50 10 10

Sample Output

735

630

0

0

題意:給你n種類型的硬幣 分別給出每種硬幣的數量和面額 現在問你最大能組成的面額(小於等於給定的面額) 是多少?

思路:標準的多重背包 二進制優化即可

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<time.h>
#include<queue>
#define ll long long int
using namespace std;
inline ll gcd(ll a,ll b){return b?gcd(b,a%b):a;}
inline ll lcm(ll a,ll b){return a/gcd(a,b)*b;}
int moth[13]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int dir[4][2]={1,0 ,0,1 ,-1,0 ,0,-1};
int dirs[8][2]={1,0 ,0,1 ,-1,0 ,0,-1, -1,-1 ,-1,1 ,1,-1 ,1,1};
const int inf=0x3f3f3f3f;
const ll mod=1000000007;
int a[15];
int value[15];
int dp[100007];
int main(){
    ios::sync_with_stdio(false);
    int mo;
    while(cin>>mo){
        memset(dp,0,sizeof(dp));
        int n;
        cin>>n;
        for(int i=1;i<=n;i++)
            cin>>a[i]>>value[i];
        dp[0]=1;
        for(int i=1;i<=n;i++){
            int temp=a[i]; int now=1;
            while(1){
                if(temp>now){
                    temp-=now;
                    for(int j=mo;j>=now*value[i];j--)
                        if(dp[j-now*value[i]])
                            dp[j]=1;
                    now*=2;
                }else{
                    for(int j=mo;j>=temp*value[i];j--)
                        if(dp[j-temp*value[i]])
                            dp[j]=1;
                        break;
                }
            }
        }
        int ans=0;
        for(int i=mo;i>=0;i--){
            if(dp[i]){
                ans=i; break;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
} 

poj 1276 Cash Machine(多重背包)