http://poj.org/problem?id=3253

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).
這個題說的是一個人要圍籬笆,有一塊木板,把它切成n份,每份i米長,而沒切割一次就收切割成兩份的總長的價格,比如8米的木板切成3,5,就要付8美元,然後問你最少付多少錢
然後我想的就是把序列從小到大排列,因為要求最小的錢,所以最大的木板切一次就夠了,小的切幾次也沒關係,所以先把所有加一遍,然後n-1個加起來,再把n-2ge加起來,……最後把所有的都加起來,
但是書上說把它看成樹,有多少層就切割多少次,所以比較小的要在最小層,先排序,之後把最小的兩個相加,把它當作一個板子,這樣就相當於有n-1個板子,依次……

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int main()
{
    int n,a[50000];
    scanf("%d",&n);
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    ll sum=0;
    while(n>1)//直到計算出短板為1
    {
       int l1=0,l2=1;
       if(a[l1]>a[l2])
       {
           swap(l1,l2);
       }
       for(int i=2;i<n;i++)
       {
           if(a[i]<a[l1])
           {
               l2=l1;
               l1=i;
           }
           else if(a[i]<a[l2])
           {
               l2=i;
           }
       }
       int s=a[l1]+a[l2];
       sum+=s;
       if(l1==n-1)
          swap(l1,l2);
       a[l1]=s;
       a[l2]=a[n-1];
       n--;

}
    printf("%lld\n",sum);
    return 0;
}