1. 程式人生 > >POJ 2299 Ultra-QuickSort

POJ 2299 Ultra-QuickSort

歸並排序 not ring cas output contain nal 歸並 accept

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 39767 Accepted: 14336

Description

技術分享In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0



歸並排序:

#include<iostream>
#include<cstring>
using namespace std;

#define M 500005
int a[M],b[M];
__int64 ans;

void mergr_sort(int x,int y)
{
	if(y-x>1)
	{
		int m=x+(y-x)/2;   //劃分
		int p=x,q=m,i=x;
		mergr_sort(x,m);    //遞歸求解
		mergr_sort(m,y);    //遞歸求解
		while(p<m || q<y)
		{
			if(q>=y || (p<m && a[p]<=a[q]))
				b[i++]=a[p++];     //把左半數組拷貝到暫時空間
			else
			{
				b[i++]=a[q++];     //把右半數組拷貝到暫時空間
				ans+=m-p;    
			}
		}
		for(i=x;i<y;i++) a[i]=b[i];
	}
}

int main()
{
	int n;
	while(cin>>n)
	{
		if(n==0)  break;
		memset(a,0,sizeof(a));
		memset(b,0,sizeof(b));
		int i;
		for(i=1;i<=n;i++)
			cin>>a[i];

		ans=0;
		mergr_sort(1,n+1);
		printf("%I64d\n",ans);
	}

	return 0;
}









POJ 2299 Ultra-QuickSort