1. 程式人生 > >hdu 5358 First One 2015多校聯合訓練賽#6 枚舉

hdu 5358 First One 2015多校聯合訓練賽#6 枚舉

input blank include word-wrap accep acc wan pre ant

First One

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 142 Accepted Submission(s): 37


Problem Description soda has an integer array a1,a2,,an. Let S(i,j) be the sum of ai,ai+1,,aj. Now soda wants to know the value below:
i=1nj=in(?log2S(i,j)?+1)×(i+j)
Note: In this problem, you can consider log20 as 0.

Input There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer n (1
n105)
, the number of integers in the array.
The next line contains n integers a1,a2,,an (0ai105).
Output For each test case, output the value.
Sample Input
1
2
1 1

Sample Output
12

Source 2015 Multi-University Training Contest 6
因為下取整log(sum)的值是非常小的。

能夠枚舉每一個位置為開始位置,然後枚舉每一個log(sum)僅僅需36*n的。

中間j的累加和

推公式就可以。

可是找log值同樣的區間,須要用log(sum)*n的復雜度預處理出來,假設每次二分位置會超時。



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
#define ll long long
#define maxn 100007
ll num[maxn];
ll pos[maxn][36];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        for(int i = 0;i < n; i++){
            scanf("%I64d",&num[i]);
        }

        num[n] = 0;
        for(ll i = 0;i < 36; i++){
            ll di = 1LL<<(i+1);
            ll su = num[0];
            int p = 0;
            for(int j = 0;j < n; j++){
                if(j) su -= num[j-1];
                while(su < di && p < n){
                    su += num[++p];
                }
                pos[j][i] = p;
            }
        }

        ll ans = 0,res;
        for(int i = 0;i < n; i++){
            ll p = i,q;
            for(int j = 0;j < 36 ;j ++){
                q = pos[i][j];
                res = (j+1)*((i+1)*(q-p)+(p+q+1)*(q-p)/2);
                ans += res;
                p = q;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}


hdu 5358 First One 2015多校聯合訓練賽#6 枚舉