1. 程式人生 > >HDU 3635 Dragon Balls(並查集)

HDU 3635 Dragon Balls(並查集)

quest text hdu ring form sse limit ould expect

Dragon Balls

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 64 Accepted Submission(s) : 26

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it‘s too difficult for Monkey King(WuKong) to gather all of the dragon balls together.
技術分享

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities‘ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2

Author

possessor WC

Source

2010 ACM-ICPC Multi-University Training Contest(19)——Host by HDU

題解:

這題的題解和之前的那題hdu 2818 Building Blocks 很像,同個寫法

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char ch[5];
int T,n,m;
int fa[10005],mov[10005],num[10005];
int findfa(int k)
{
    if (fa[k]==k) return k;
    int faa=fa[k];
    fa[k]=findfa(fa[k]);
    mov[k]+=mov[faa];
    return fa[k];
}
void uni(int x,int y)
{
    int fx=findfa(x);
    int fy=findfa(y);
    if (fx==fy) return;
    fa[fx]=fy;
    num[fy]+=num[fx];
    mov[fx]=1;//這裏不是很理解,我覺得在底部的那個也可能一直移來移去,為什麽底部的就是只移了一次。

}
int main()
{
    while(~scanf("%d",&T))
    {
    for(int cas=1;cas<=T;cas++)
    {
        printf("Case %d:\n",cas);
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        {
            fa[i]=i;
            num[i]=1;
            mov[i]=0;
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%s",&ch);
            if (ch[0]==T)
            {
                int x,y;
                scanf("%d%d",&x,&y);
                uni(x,y);
            }
            else
            {
                int x;
                scanf("%d",&x);
                findfa(x);
                printf("%d %d %d\n",fa[x],num[fa[x]],mov[x]);
            }
        }
    }
    }
    return 0;
}

HDU 3635 Dragon Balls(並查集)