1. 程式人生 > >【hdu1280】前M大的數

【hdu1280】前M大的數

tdi bmi space fin name class dig 隊列 math

前m大的數

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19208 Accepted Submission(s): 6563

Problem Description 還記得Gardon給小希布置的那個作業麽?(上次比賽的1005)其實小希已經找回了原來的那張數表,現在她想確認一下她的答案是否正確,但是整個的答案是很龐大的表,小希只想讓你把答案中最大的M個數告訴她就可以了。
給定一個包含N(N<=3000)個正整數的序列,每個數不超過5000,對它們兩兩相加得到的N*(N-1)/2個和,求出其中前M大的數(M<=1000)並按從大到小的順序排列。 Input
輸入可能包含多組數據,其中每組數據包括兩行:
第一行兩個數N和M,
第二行N個數,表示該序列。

Output 對於輸入的每組數據,輸出M個數,表示結果。輸出應當按照從大到小的順序排列。 Sample Input 4 4 1 2 3 4 4 5 5 3 6 4 Sample Output 7 6 5 5 11 10 9 9 8 Author Gardon Source 杭電ACM集訓隊訓練賽(VI) Recommend lcy 試題分析:這道題非常簡單,用堆模擬就好了,學會手寫堆在做以後堆的題目比較方便些 手寫堆代碼:
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
//#include<cmath>

using namespace std;
const int INF = 9999999;
#define LL long long

inline int read(){
    int x=0,f=1;char c=getchar();
    for(;!isdigit(c);c=getchar()) if(c==‘-‘) f=-1;
    for(;isdigit(c);c=getchar()) x=x*10+c-‘0‘;
    return x*f;
}
int N,M;
int a[100001];
int heap[100001];
int len; 

void insert(int x){
    heap[++len]=x;
    for(int k=len;k!=1;k/=2){
        if(heap[k]<heap[k/2]) swap(heap[k],heap[k/2]);
        else break;
    }
    return ;
}
void delet(){
    if(len==0) return ;
    heap[1]=heap[len];len--;
    for(int k=1;k*2<=len;){
        if((k*2<=len)&&(k*2+1>len)){
            if(heap[k*2]<heap[k]) swap(heap[k*2],heap[k]),k*=2;
            else break;
        }
        else{
            if(heap[k*2]<heap[k]||heap[k*2+1]<heap[k]){
                if(heap[k*2]<heap[k*2+1]) swap(heap[k],heap[k*2]),k*=2;
                else swap(heap[k],heap[k*2+1]),k*=2,k++;
            }
            else break;
        }
    }
    return ;
}
int ans[100001];
int main(){
    //freopen(".in","r",stdin);
    //freopen(".out","w",stdout);
    while(scanf("%d%d",&N,&M)!=EOF){
        len=0;
        for(int i=1;i<=N;i++) a[i]=read();
        for(int i=1;i<=N;i++)
            for(int j=i+1;j<=N;j++){
			    insert(a[i]+a[j]);
			    if(len>M) delet();
			}
        for(int i=1;i<=M;i++) ans[i]=heap[1],delet();
        for(int i=M;i>1;i--) printf("%d ",ans[i]);
        printf("%d\n",ans[1]); 
    }
    return 0;
}

優先隊列代碼:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<stack>
#include<vector>
#include<algorithm>
//#include<cmath>

using namespace std;
const int INF = 9999999;
#define LL long long

inline int read(){
    int x=0,f=1;char c=getchar();
    for(;!isdigit(c);c=getchar()) if(c==‘-‘) f=-1;
    for(;isdigit(c);c=getchar()) x=x*10+c-‘0‘;
    return x*f;
}
int N,M;
priority_queue<int ,vector<int> , greater<int> > Que;
int a[100001];
int ans[100001];
int main(){
    //freopen(".in","r",stdin);
    //freopen(".out","w",stdout);
    while(scanf("%d%d",&N,&M)!=EOF){
        for(int i=1;i<=N;i++) a[i]=read();
        for(int i=1;i<=N;i++)
            for(int j=i+1;j<=N;j++){
               Que.push(a[i]+a[j]);
               if(Que.size()>M) Que.pop();
            }
        for(int i=1;i<=M;i++) ans[i]=Que.top(),Que.pop();
        for(int i=M;i>1;i--) printf("%d ",ans[i]);
        printf("%d\n",ans[1]); 
    }
    return 0;
}

  

  

【hdu1280】前M大的數