1. 程式人生 > >【BZOJ3680】吊打XXX 模擬退火

【BZOJ3680】吊打XXX 模擬退火

esc 題解 ret 爬山 能量 truct style namespace ngx

【BZOJ3680】吊打XXX

Description

gty又虐了一場比賽,被虐的蒟蒻們決定吊打gty。gty見大勢不好機智的分出了n個分身,但還是被人多勢眾的蒟蒻抓住了。蒟蒻們將n個gty吊在n根繩子上,每根繩子穿過天臺的一個洞。這n根繩子有一個公共的繩結x。吊好gty後蒟蒻們發現由於每個gty重力不同,繩結x在移動。蒟蒻wangxz腦洞大開的決定計算出x最後停留處的坐標,由於他太弱了決定向你求助。
不計摩擦,不計能量損失,由於gty足夠矮所以不會掉到地上。

Input

輸入第一行為一個正整數n(1<=n<=10000),表示gty的數目。
接下來n行,每行三個整數xi,yi,wi,表示第i個gty的橫坐標,縱坐標和重力。

對於20%的數據,gty排列成一條直線。
對於50%的數據,1<=n<=1000。
對於100%的數據,1<=n<=10000,-100000<=xi,yi<=100000

Output

輸出1行兩個浮點數(保留到小數點後3位),表示最終x的橫、縱坐標。

Sample Input

3
0 0 1
0 2 1
1 1 1

Sample Output

0.577 1.000

題解:設繩結最後的位置為(x,y),那麽一定滿足∑g[i]*sqrt((x-xi)2+(y-yi)2)最小。所以就變成了模擬退火的板子題了。

當然,爬山也可以做,就是每次算出當前點受到的合外力方向,然後一直朝著那個方向移動就行了。(然而我物理學的不好啊QAQ)

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <cstdlib>
using namespace std;
const int maxn=10010;
double minn,T;
int n;
struct point
{
	double x,y;
}p[maxn],ans,now,neo;
double g[maxn];
double Rand()
{
	return rand()%1000/1000.0;
}
double sqr(double x)
{
	return x*x;
}
double solve(point a)
{
	double ret=0;
	for(int i=1;i<=n;i++)	ret+=g[i]*sqrt(sqr(a.x-p[i].x)+sqr(a.y-p[i].y));
	if(ret<minn)	ans=a,minn=ret;
	return ret;
}
int main()
{
	scanf("%d",&n);
	srand(2333666);
	int i;
	for(i=1;i<=n;i++)	scanf("%lf%lf%lf",&p[i].x,&p[i].y,&g[i]),now.x+=p[i].x,now.y+=p[i].y;
	now.x/=n,now.y/=n,minn=9223372036854775807.0,solve(now);
	T=1000000;
	while(T>0.001)
	{
		neo.x=now.x+T*(Rand()+Rand()-1.0);
		neo.y=now.y+T*(Rand()+Rand()-1.0);
		double de=solve(now)-solve(neo);
		if(de>0||exp(de/T)>Rand())	now=neo;
		T*=0.993;
	}
	for(i=1;i<=1000;i++)
	{
		neo.x=ans.x+T*(Rand()+Rand()-1.0);
		neo.y=ans.y+T*(Rand()+Rand()-1.0);
		solve(neo);
	}
	printf("%.3lf %.3lf",ans.x,ans.y);
	return 0;
}

【BZOJ3680】吊打XXX 模擬退火