1. 程式人生 > >1014: [JSOI2008]火星人prefix

1014: [JSOI2008]火星人prefix

很快 scan splay 每一個 prefix 超過 文件 switch 插入字符

1014: [JSOI2008]火星人prefix

Time Limit: 10 Sec Memory Limit: 162 MB Submit: 7820 Solved: 2487 [Submit][Status][Discuss]

Description

  火星人最近研究了一種操作:求一個字串兩個後綴的公共前綴。比方說,有這樣一個字符串:madamimadam, 我們將這個字符串的各個字符予以標號:序號: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 現在, 火星人定義了一個函數LCQ(x, y),表示:該字符串中第x個字符開始的字串,與該字符串中第y個字符開始的字串 ,兩個字串的公共前綴的長度。比方說,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函數的過程 中,火星人發現了這樣的一個關聯:如果把該字符串的所有後綴排好序,就可以很快地求出LCQ函數的值;同樣, 如果求出了LCQ函數的值,也可以很快地將該字符串的後綴排好序。 盡管火星人聰明地找到了求取LCQ函數的快速 算法,但不甘心認輸的地球人又給火星人出了個難題:在求取LCQ函數的同時,還可以改變字符串本身。具體地說 ,可以更改字符串中某一個字符的值,也可以在字符串中的某一個位置插入一個字符。地球人想考驗一下,在如此 復雜的問題中,火星人是否還能夠做到很快地求取LCQ函數的值。

Input

  第一行給出初始的字符串。第二行是一個非負整數M,表示操作的個數。接下來的M行,每行描述一個操作。操 作有3種,如下所示 1、詢問。語法:Qxy,x,y均為正整數。功能:計算LCQ(x,y)限制:1<=x,y<=當前字符串長度。 2、修改。語法:Rxd,x是正整數,d是字符。功能:將字符串中第x個數修改為字符d。限制:x不超過當前字 符串長度。 3、插入:語法:Ixd,x是非負整數,d是字符。功能:在字符串第x個字符之後插入字符d,如果x=0,則在字 符串開頭插入。限制:x不超過當前字符串長度

Output

  對於輸入文件中每一個詢問操作,你都應該輸出對應的答案。一個答案一行。

Sample Input

madamimadam
7
Q 1 7
Q 4 8
Q 10 11
R 3 a
Q 1 7
I 10 a
Q 2 11

Sample Output

5
1
0
2
1

HINT

1、所有字符串自始至終都只有小寫字母構成。
2、M<=150,000
3、字符串長度L自始至終都滿足L<=100,000
4、詢問操作的個數不超過10,000個。
對於第1,2個數據,字符串長度自始至終都不超過1,000
對於第3,4,5個數據,沒有插入操作。

對於沒有插入的情況,用O(L)的時間預處理hash值,然後二分長度,再用O(1)的時間判斷是否存在,單次詢問的時間復雜度為O(log(L))

加入插入之後,可以用Splay維護區間hash值,然後類似上面,只是需要額外的O(log(L))的時間提取出區間,單次詢問的時間復雜度為O(log(L) * log(L))

#include <cstdio>
#include <cstring>
const int maxn = 110000 + 10;
typedef unsigned long long ll;
const ll seed = 131;
char val[maxn];
int tot, root, fa[maxn], son[maxn][2], siz[maxn], cnt = 0;
ll hash[maxn], pow[maxn];
inline void PushUp(int rt){
    siz[rt] = siz[son[rt][0]] + siz[son[rt][1]] + 1;
    hash[rt] = hash[son[rt][0]] + val[rt] * pow[siz[son[rt][0]]] + hash[son[rt][1]] * pow[siz[son[rt][0]] + 1];
}
inline void Rotate(int x){
    int f = fa[x], p = son[f][0] == x;
    son[f][!p] = son[x][p];
    fa[son[x][p]] = f;
    fa[x] = fa[f];
    if(fa[x]) son[fa[x]][son[fa[x]][1] == f] = x;
    son[x][p] = f;
    fa[f] = x;
    PushUp(f);
}
inline void Splay(int x, int t){
    int y, z;
    while(fa[x] != t){
        if(fa[fa[x]] == t) Rotate(x);
        else{
            y = fa[x];
            z = fa[y];
            if(son[y][1] == x ^ son[z][1] == y) Rotate(x);
            else Rotate(y);
            Rotate(x);
        }
    }
    PushUp(x);
    if(!t) root = x;
}
inline void Find(int kth, int t){
    int x = root, tmp;
    while(x){
        tmp = siz[son[x][0]];
        if(kth == tmp + 1){
            Splay(x, t);
            return;
        }
        else if(kth < tmp + 1) x = son[x][0];
        else{
            x = son[x][1];
            kth -= tmp + 1;
        }
    }
}
char s[maxn];
int Insert(int st, int en){
    if(st > en) return 0;
    int mid = st + en >> 1, now = ++cnt;
    val[now] = s[mid];
    son[now][0] = Insert(st, mid - 1);
    if(son[now][0]) fa[son[now][0]] = now;
    son[now][1] = Insert(mid + 1, en);
    if(son[now][1]) fa[son[now][1]] = now;
    PushUp(now);
    return now;
}
inline void LCQ(){
    int x, y;
    scanf("%d %d", &x, &y);
    int l = 1, r = tot, mid, ret = 0;
    ll tmp;
    while(l <= r){
        mid = l + r >> 1;
        if(y + mid - 1 > tot)    r = mid - 1;
        else{
            Find(x, 0);
            Find(x + mid + 1, root);
            tmp = hash[son[son[root][1]][0]];
            Find(y, 0);
            Find(y + mid + 1, root);
            if(tmp == hash[son[son[root][1]][0]]){
                ret = mid;
                l = mid + 1;
            }
            else r = mid - 1;
        }
    }
    printf("%d\n", ret);
}
int main(){
    pow[0] = 1;
    for(int i = 1; i < maxn; i++)
        pow[i] = pow[i - 1] * seed;
    siz[0] = hash[0] = fa[0] = son[0][0] = son[0][1] = 0;
    scanf("%s", s + 1);
    tot = strlen(s + 1);
    root = Insert(0, tot + 1);
    int m;
    scanf("%d", &m);
    char opt[5], d[5];
    int x, y, t;
    while(m--){
        scanf("%s", opt);
        switch(opt[0]){
            case I:
                scanf("%d%s", &x, d);
                Find(x + 1, 0);
                Find(x + 2, root);
                cnt++;
                val[cnt] = d[0];
                fa[cnt] = son[root][1];
                son[son[root][1]][0] = cnt;
                PushUp(cnt);
                PushUp(son[root][1]);
                PushUp(root);
                tot++;
                break;
            case R:
                scanf("%d%s", &x, d);
                Find(x, 0);
                Find(x + 2, root);
                t = son[son[root][1]][0];
                val[t] = d[0];
                PushUp(t);
                PushUp(son[root][1]);
                PushUp(root);
                break;
            case Q:
                LCQ();
                break;
        }
    }
    return 0;
}

1014: [JSOI2008]火星人prefix