1. 程式人生 > >1058. A+B in Hogwarts (20)

1058. A+B in Hogwarts (20)

you turn fan explained names world printf blog tput

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107

], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
	int Galleon1,sickle1,knut1;
	int g_sum=0,s_sum=0,k_sum=0;
	scanf("%d.%d.%d %d.%d.%d",&Galleon1,&sickle1,&knut1,&g_sum,&s_sum,&k_sum);
	g_sum+=Galleon1;
	s_sum+=sickle1;
	k_sum+=knut1;
	int flag = k_sum/29;
	k_sum = k_sum%29;
	s_sum+=flag;
	flag=s_sum/17;
	s_sum=s_sum%17;
	g_sum+=flag;
	printf("%d.%d.%d\n",g_sum,s_sum,k_sum);
	return 0;
}

  

1058. A+B in Hogwarts (20)