1. 程式人生 > >浙大pat甲級題目---1032. Sharing (25)

浙大pat甲級題目---1032. Sharing (25)

res which mmx suffix ecif 單詞 list title mco

1032. Sharing (25)

時間限制 100 ms 內存限制 65536 kB 代碼長度限制 16000 B 判題程序 Standard 作者 CHEN, Yue

To store English words, one method is to use linked lists and store a word letter by letter. To save some space, we may let the words share the same sublist if they share the same suffix. For example, "loading" and "being" are stored as showed in Figure 1.

技術分享圖片
Figure 1

You are supposed to find the starting position of the common suffix (e.g. the position of "i" in Figure 1).

Input Specification:

Each input file contains one test case. For each case, the first line contains two addresses of nodes and a positive N (<= 105), where the two addresses are the addresses of the first nodes of the two words, and N is the total number of nodes. The address of a node is a 5-digit positive integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is the letter contained by this node which is an English letter chosen from {a-z, A-Z}, and Nextis the position of the next node.

Output Specification:

For each case, simply output the 5-digit starting position of the common suffix. If the two words have no common suffix, output "-1" instead.

Sample Input 1:
11111 22222 9
67890 i 00002
00010 a 12345
00003 g -1
12345 D 67890
00002 n 00003
22222 B 23456
11111 L 00001
23456 e 67890
00001 o 00010
Sample Output 1:
67890
Sample Input 2:
00001 00002 4
00001 a 10001
10001 s -1
00002 a 10002
10002 t -1
Sample Output 2:
-1
題目大意:就是尋找共享的節點
題目解法:我原本的想法是分離第一個單詞和第二個單詞,然後遍歷查找第二個單詞和第一個單詞重復的部分。這方法太笨了,最後兩個測試點超時。
後來看了一個題解,發現人家解法精妙,代碼很短。簡單來說就是用數組存,每個node有一個flag變量用來查看是否遍歷過。
首先按鏈表順序訪問word1,將其標為true,再訪問第二個。
我居然沒想到。。。
https://blog.csdn.net/sy_yu/article/details/54909198
這是代碼地址,我也copy一下貼出來吧
#include<stdio.h>

#define MAX_N 1000100

struct Node{
    char data;
    int next;
    bool flag;//用flag遍歷一遍就好
}node[MAX_N];

void init(){
    for(int i=0;i<MAX_N;i++){
        node[i].flag=false;
    }
}

int main(){
    init();
    int n;
    int l1,l2;
    int address,next;
    char data;
    int p;
    scanf("%d%d%d",&l1,&l2,&n);

    for(int i=0;i<n;i++){
        scanf("%d %c %d",&address,&data,&next);
        node[address].data=data;
        node[address].next=next;
    }
    for(int i=l1;i!=-1;i=node[i].next){
        node[i].flag=true;
    }
    for(p=l2;p!=-1;p=node[p].next){
        if(node[p].flag)
            break;
    }
    if(p!=-1)
        printf("%05d",p);
    else
        printf("-1");
}

浙大pat甲級題目---1032. Sharing (25)