1. 程式人生 > >解題報告 之 HDU 4405 Aeroplane chess

解題報告 之 HDU 4405 Aeroplane chess

解題報告 之 HDU 4405 Aeroplane chess


Description

Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N. 

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid. 

Please help Hzz calculate the expected dice throwing times to finish the game. 
 

Input

There are multiple test cases. 
Each test case contains several lines. 
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000). 
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N).   
The input end with N=0, M=0. 
 

Output

For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point. 
 

Sample Input


     
      2 0 8 3 2 4 4 5 7 8 0 0 
      
     
    
      
     
    
   
   
   

Sample Output


     
      1.1667 2.3441 
      
     
    
      
     
    
   
  

Source

2012 ACM/ICPC Asia Regional Jinhua Online
題目大意:下飛行棋,你從0開始投擲一枚均勻的骰子(1~6)。投中哪個數就走幾步,直到走到大於等於n則遊戲結束。地圖上還有m條航線可以直接把你帶到更遠的地方。一旦走到航線起點,則立即飛往航線終點且不用投擲骰子,如果航線1的終點是航線2的起點則連續飛兩次。不存在兩條航線起點相同。問遊戲結束所需要的步數期望。

分析:一道大水概率DP,狀態轉移方程非常好想。對於某個點u,如果它是某航線的起點,那麼它的期望就直接等於該航線終點v的步數期望,即dp[ui]=dp[vi]。因為此時 u 只能轉移到 v 。如果點u不是航線起點,那麼它就等可能的轉移到i+1,+2,+3,+4,+5,+6。那麼dp[i]=∑1.0/6.0*dp[i+j],j=1,2,3,4,5,6。
最後就是注意要清零陣列。
上程式碼:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;

const int MAXN = 1e5 + 10;
int line[MAXN];
double dp[MAXN];


int main()
{
	int n, m;
	while(scanf( "%d%d", &n, &m ) == 2)
	{
		if(n == 0 && m == 0) break;
		memset( line, -1, sizeof line );
		memset( dp, 0, sizeof dp );
		int u, v;
		for(int i = 1; i <= m; i++)
		{
			scanf( "%d%d", &u, &v );
			line[u] = v;
		}
		for(int i = n-1; i >= 0; i--)
		{
			if(line[i] != -1)
			{
				dp[i] = dp[line[i]];
			}
			else
			{
				for(int j = 1; j <= 6; j++)
				{
					dp[i] += dp[i + j];
				}
				dp[i] /= 6.0;
				dp[i] += 1.0;
			}
		}
		printf( "%.4lf\n", dp[0] );
	}

	return 0;
}