1. 程式人生 > >查詢某一個數

查詢某一個數

Description
輸入一個從小到大排列的有序數列(長度小於100),在此數列中查詢某一個數x,若找到,輸出相應下標,否則,輸出”Not Found".

Input
先輸入要查詢的數x和n, 再輸入n個有序數。

Output
輸出x所在位置下標或"Not Found"

Sample Input
2 8 -2 2 3 8 9 20 25 67
5 7 -2 2 3 8 9 20 25
Sample Output
1
Not Found

#include<stdio.h>
int main()
{
int n,x,a[100],i,s,j;
while(scanf("%d",&x)!=EOF)
{
scanf("%d",&n);
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
}
s=-1;
for(j=0;j<n;j++)
{
if(a[j]x)
{
printf("%d\n",j);
s=j;
break;
}
}
if(s

-1)
printf(“Not Found\n”);
}
return 0;
}