1. 程式人生 > >自負雜湊,字典樹——Message Flood(未解決)

自負雜湊,字典樹——Message Flood(未解決)

Message Flood

Time Limit: 1500 ms Memory Limit: 65536 KiB

Submit Statistic Discuss

Problem Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

3

Step 1:題意,個人理解,多組輸入,第一行裡輸入n,m,當n=0的時候結束。

接下來n行,輸入n個名字;接下來m行輸入m個名字;

然後在n中把m中出現的名字去掉,最後輸出剩下幾個。(m中可能有n中沒出現過的,無需處理)

Tips:應該可以用雜湊做,因為這個題分類屬於 字元雜湊,還有用字典樹的(原諒我的無知,我不會)~

Step 2:實現。(可惜WA,而且應該還會超時.....)

#include<stdio.h>
#include<string.h>
struct node
{
    char name[25];
} L[20008],Q[20008];
int main()
{
    int  n, i, j,m,sum;
    while(~scanf("%d",&n)&&n!=0)
    {
        scanf("%d",&m);
        int flag[20008] = {0};
        for(i = 1; i <= n; i++)
        {
            scanf("%s",L[i].name);
        }
        for(j = 1; j <= m; j++)
        {
            scanf("%s",Q[j].name);
        }
        j = 1;i = 1;sum = n;
        while(i <= n&&j<=m)
        {
            if(strcmp(Q[j].name,L[i].name) == 0 && !flag[i])
            {
                flag[i] = 1;
                sum--;
                j++;i=0;
            }
            else
            {
                i++;
            }
        }
        printf("%d\n",sum);
       
    }
    return 0;
}

附上網友字典樹做的:

#include <stdio.h>
#include <string.h>
#include <algorithm>

struct node
{
    int v;
    node *next[26];
};
node *newnode()
{
    node *p=new node;
    p->v=0;
    for(int i=0;i<26;i++)
    {
        p->next[i]=NULL;
    }
    return p;
}
void insertnode(node *root,char *str)
{
    node *p=root;
    int l=strlen(str);
    for(int i=0;i<l;i++)
    {
        int t;
        if(str[i]>='a')
            t=str[i]-'a';
        else t=str[i]-'A';
        if(p->next[t]==NULL)
        {
            p->next[t]=newnode();
        }
        p=p->next[t];
    }
    p->v=1;
}
int find(node *root,char *str)
{
    node *p=root;
    int l=strlen(str);
    for(int i=0;i<l;i++)
    {
        int t;
        if(str[i]>='a')
            t=str[i]-'a';
        else t=str[i]-'A';
        if(p->next[t]==NULL)
            return 0;
        else p=p->next[t];
    }
    if(p->v==1)
        return 1;
    return 0;
}
int main()
{
    int n,m;
    int i;
    char name[30000][15],send[100000];
    while(~scanf("%d",&n)&&n)
    {
        int c=0;
        node *root=newnode();
        scanf("%d%*c",&m);
        for(i=0;i<n;i++)
        {
            scanf("%s",name[i]);
        }
        for(i=0;i<m;i++)
        {
            scanf("%s",send);
            insertnode(root,send);
        }
        for(i=0;i<n;i++)
        {
            if(!find(root,name[i]))
                c++;
        }
        printf("%d\n",c);
    }
}

還有位同學使用map函式做的,不貼碼,貼地址