1. 程式人生 > >PAT 1028 List Sorting (25 分)關於 Cin Cout 最後一個測試例項超時 燚

PAT 1028 List Sorting (25 分)關於 Cin Cout 最後一個測試例項超時 燚

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

 大意:按給定資訊將列表排序

輸入:第一行:N為輸入的資料(N小於等於100000),C為按第幾列排序

          後面N行:ID 姓名  分數

輸出:將列表按第C列從小到大排序  如果出現C列有兩個或者以上相等的情況則按ID號由小到大進行排序

思想:分三種情況定義3個比較函式

坑點:1.如果用C++ 中的std::cin>>和std::cout<<最後一個測試樣例執行超時。

           2.在main()函式中定義陣列array[100000]可能 會爆棧。

知識點:在函式中定義的陣列實在棧中  但系統棧是有限的,所以如果陣列太大會爆掉,因此可以將他定義在函式之外作為全域性變數,全域性變數儲存在靜態儲存區。(如有錯誤請留言,歡迎指正)。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct Student{
	char id[10];
	char name[10];
	int grade;
};
Student student[100001];
void input(int n){
	for(int i=0;i<n;i++){
		scanf("%s%s%d",student[i].id,student[i].name,&student[i].grade);

	}
}
int compare1(Student &a,Student &b){
	return strcmp(a.id,b.id)<0;
}
int compare2(Student &a,Student &b){
	if(strcmp(a.name,b.name))
		return strcmp(a.name,b.name)<0;
	return strcmp(a.id,b.id)<0;
} 
int compare3(Student &a,Student &b){
	if(a.grade!=b.grade)
		return a.grade<b.grade;
	return strcmp(a.id,b.id)<0;
}
int main(){
	int n,c;
	scanf("%d%d",&n,&c);
	input(n);
	switch(c){
		case 1:sort(student,student+n,compare1);break;
		case 2:sort(student,student+n,compare2);break;
		case 3:sort(student,student+n,compare3);break;
	}
	for(unsigned int i=0;i<n;i++){
		printf("%s %s %d\n",student[i].id,student[i].name,student[i].grade);
	}
}