1. 程式人生 > >再遇結構體- A - DNA Sorting

再遇結構體- A - DNA Sorting

A - DNA Sorting

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from most sorted'' to

least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.
Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
這道題本來暴力迴圈排序就可以了,結果智障的小菜雞陣列開小了,一直Runtime Error 
誤以為迴圈超時,又去部落格看了看大牛的解法,再次拾起了結構體,
順帶了解了一波c++的sort和stable_sort;前前後後改了兩個小時
最後發現是陣列開小了,真是被自己蠢笑了

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include<stdlib.h>
using namespace std;
struct DNA
{
	string dna;
	int len;
};
bool compare(DNA x,DNA y)
{
	return x.len<y.len;
}
int main()
{
	struct DNA a[102];
	int i,j,n,m;
	scanf("%d%d",&n,&m);
	for(i=0;i<m;i++)
	{
		cin>>a[i].dna;
		a[i].len=0;
		for(j=0;j<=n-2;j++)
		{
			for(int k=j+1;k<=n-1;k++)
			{
				if(a[i].dna[j]>a[i].dna[k])
				{
					a[i].len++;
				}
			}
		}
	}
	stable_sort(a,a+m,compare);
	for(i=0;i<m;i++)
	{
		cout<<a[i].dna<<endl;
	}
	return 0;
}