1. 程式人生 > >1115 Counting Nodes in a BST (30 分)

1115 Counting Nodes in a BST (30 分)

1115 Counting Nodes in a BST (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

人果然不能瞎偷懶,因為上題也是二叉搜尋的就懶得改。。。。然後後來就造成。。改了好久的bug只是因為。。。上題的問題和這題有點區別 心塞塞

#include<bits/stdc++.h>
using namespace std;
struct node
{
	int v;
	struct node*left, *right;
	int flag;
};
int digit[1005] = {0};
node * Insert(node *tree , int val)
{
	if(tree == NULL)
	{
		tree = new node;
		tree->v = val;
		tree->left = tree->right = NULL;
		tree->flag = 0;
		return tree;
	}
	if(val<= tree->v) //插在左子樹 
		tree->left = Insert(tree->left, val);
	else 
		tree->right = Insert(tree->right, val);
	return tree; 
}//因為紅黑樹是二叉搜尋樹 所以可以根據他們的排序建樹並且給出的是先序排序 
int BFS(node * tree)
{
	queue<node*>qu;
	tree->flag = 1;
	qu.push(tree);
	int maxn = -1;
	while(!qu.empty())
	{
		node *tmp = qu.front();
		qu.pop();
		maxn = max(maxn, tmp->flag);
		if(tmp->left != NULL)
		{
			tmp->left->flag = tmp->flag + 1; 
			qu.push(tmp->left);
		}
		if(tmp->right != NULL)
		{
			tmp->right->flag = tmp->flag + 1; 
			qu.push(tmp->right);
		}
		digit[tmp->flag] ++;
	}
	return maxn;//表示最後一層的層數在哪裡 
}
int main()
{
	int n, x;
	scanf("%d", &n);
	node *tree = NULL;
	for(int i = 1; i <= n; i++)
	{
	 	scanf("%d", &x);
		tree = Insert(tree,x);
	} 
	int last = BFS(tree);
	printf("%d + %d = %d\n",digit[last],digit[last - 1],digit[last] + digit[last - 1]);
	return 0;	 
} 

程式碼: