1. 程式人生 > >1060 Are They Equal (25 分)

1060 Are They Equal (25 分)

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as 0.123×105​​ with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers N, A and B, where N (<100) is the number of significant digits, and A and B are the two float numbers to be compared. Each float number is non-negative, no greater than 10100​​, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line YES if the two numbers are treated equal, and then the number in the standard form 0.d[1]...d[N]*10^k (d[1]>0 unless the number is 0); or NO if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3
#include<cstdio>
#include<string>
#include<iostream>
using namespace std;
int n;//有效位數
string deal(string s,int &e){
    int k=0;//s的下標
    while(s.length()>0&&s[0]=='0'){
        s.erase(s.begin());//去掉s的前導0 
    } 
    if(s[0]=='.'){
        s.erase(s.begin());//去掉前導0後是小數點,說明s是小於1的小數
        while(s.length()>0&&s[0]=='0'){
            s.erase(s.begin());//去掉小數點後非零位前的所有零
            e--;//每去掉一個零,指數e減1 
        } 
    } else{//去掉所有前導零後不是小數點,則找到後面的小數點刪除 
        while(k<s.length()&&s[k]!='.'){
            k++;
            e++;//只要不碰到小數點就讓指數e++ 
        }
        if(k<s.length()){//while結束後k<s.length(),說明碰到了小數點 
            s.erase(s.begin()+k);//把小數點刪除 
        }
    }
    if(s.length()==0){
        e=0;//如果去掉前導零後s的長度變為0,說明這個數為0 
    }
    int num=0;
    k=0;
    string res;
    while(num<n){
        if(k<s.length())res+=s[k++];//只要還有數字,就加到res末尾
        else res+='0';//否則res末尾新增0
        num++;//精度加1 
    } 
    return res;
}
 
int main(){
    string s1,s2,s3,s4;
    cin>>n>>s1>>s2;
    int e1=0,e2=0;//e1,e2為s1與s2的指數
    s3=deal(s1,e1);
    s4=deal(s2,e2);
    if(s3==s4&&e1==e2){
        cout<<"YES 0."<<s3<<"*10^"<<e1<<endl;
    } else{
        cout<<"NO 0."<<s3<<"*10^"<<e1<<" 0."<<s4<<"*10^"<<e2<<endl;
    }
    return 0;
}