1. 程式人生 > >1085. Perfect Sequence (25)-PAT甲級真題

1085. Perfect Sequence (25)-PAT甲級真題

Given a sequence of positive integers and another positive integer p. The sequence is said to be a “perfect sequence” if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.
Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:
For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:
10 8
2 3 20 4 5 1 6 7 8 9
Sample Output:
8

 

簡單題。首先將數列從小到大排序,設當前結果為result = 0,當前最長長度為temp = 0;從i = 0~n,j從i + result到n,【因為是為了找最大的result,所以下一次j只要從i的result個後面開始找就行了】每次計算temp若大於result則更新result,最後輸出result的值~

#include <iostream>
#include <algorithm>
#include <vector>
using namespace std;
int main() {
    int n;
    long long p;
    scanf("%d%lld", &n, &p);
    vector<int> v(n);
    for (int i = 0; i < n; i++)
        cin >> v[i];
    sort(v.begin(), v.end());
    int result = 0, temp = 0;
    for (int i = 0; i < n; i++) {
        for (int j = i + result; j < n; j++) {
            if (v[j] <= v[i] * p) {
                temp = j - i + 1;
                if (temp > result)
                    result = temp;
            } else {
                break;
            }
        }
    }
    cout << result;
    return 0;
}

如果熟練使用upper_bound(),可以使用以下解法解決問題

#include <iostream>
#include <algorithm>
#include <stdlib.h>
using namespace std;
 
int main() {
	int n;
	long long p;
	cin >> n >> p;
	if (n == 0) {
		cout << n;
		return 0;
	}
	long long int *a = new long long int[n];
	for (int i = 0; i < n; i++)
		cin >> a[i];
	sort(a, a + n);
	int result = 1;
	for (int i = 0; i < n; i++) {
		result = max((int)(upper_bound(a, a+n, a[i] * p) - (a+i)), result);
	}
	cout << result;
	return 0;
}